Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Contract dates appear to renew incorrectly in Microsoft Dynamics CRM


View products that this article applies to.

Symptoms

Renewing an expired contract may appear incorrect when the Contract End Date is calculated 

↑ Back to the top


Cause

The contract renewal design is based on keeping the contract duration the same for the renewed contract as the previous contract. This is calculated based on the number of days in the original contract. For example, if a contract was saved with a start and end date one year apart, in most years this will save as 365 days. However, when renewed over a leap year, it will still use the 365 days and then display as expiring one day sooner than anticipated.

↑ Back to the top


Resolution

The duration in days is displayed on the contract form. As such, a contract may need to be modified to work for the intended time period as the days might not map as anticipated. 

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2536251
Revision : 1
Created on : 1/7/2017
Published on : 4/20/2012
Exists online : False
Views : 228