Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Some CPU cores are parked while other active CPU cores have a heavy workload in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that uses a multicore processor and that is running Windows Server 2008 R2.
  • You install the Hyper-V server role on the computer, and then you run some virtual machines (VMs) on the computer.
  • The VMs process a heavy workload.
In this scenario, the CPU usage for the VMs reaches 100 percent. However, some CPU cores are idle on the host computer.

If you open Resource Monitor, Resource Monitor indicates that some CPU cores have a high workload and that other CPU cores are idle in a parked status.

↑ Back to the top


Cause

This issue occurs because Power Manager does not unpark CPU cores correctly.

When Power Manager runs in the Hyper-V root partition, Power Manager reads two variables from a page that is shared with the hypervisor to calculate the idle time of a processor. However, Power Manager may read meaningless values because of a hypervisor interception. Therefore, the power manager calculates an incorrect idle time for the processor and does not unpark CPU cores correctly.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, you must have the Hyper-V server role installed.

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.20xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe6.1.7600.209425,475,71213-Apr-201105:26x64
Ntoskrnl.exe6.1.7601.217025,562,24013-Apr-201105:14x64
Ntkrnlpa.exe6.1.7600.209423,967,87213-Apr-201104:53Not applicable
Ntoskrnl.exe6.1.7600.209423,911,55213-Apr-201104:53Not applicable
Ntkrnlpa.exe6.1.7601.217023,967,87213-Apr-201105:59Not applicable
Ntoskrnl.exe6.1.7601.217023,912,57613-Apr-201105:59Not applicable

↑ Back to the top


Workaround

To work around this issue, change the Power Plan setting to High Performance.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_137aa4b49a07bf605b8313cdb7ec2281_31bf3856ad364e35_6.1.7600.20942_none_3ed3b2c5c570c2ff.manifest
File versionNot applicable
File size699
Date (UTC)13-Apr-2011
Time (UTC)18:59
PlatformNot applicable
File nameAmd64_1a424780b6e69a0e155e51c62af3c2f2_31bf3856ad364e35_6.1.7601.21702_none_26a61d7f8c6bc47d.manifest
File versionNot applicable
File size699
Date (UTC)13-Apr-2011
Time (UTC)18:59
PlatformNot applicable
File nameAmd64_284971b7f7169c17834dd846c9ac9664_31bf3856ad364e35_6.1.7600.20942_none_d827b4bbccfe0cba.manifest
File versionNot applicable
File size1,042
Date (UTC)13-Apr-2011
Time (UTC)18:59
PlatformNot applicable
File nameAmd64_2b6f61612d88969272cbe20462d18953_31bf3856ad364e35_6.1.7601.21702_none_a46af32443f56215.manifest
File versionNot applicable
File size701
Date (UTC)13-Apr-2011
Time (UTC)18:59
PlatformNot applicable
File nameAmd64_4fde11903434148dc142c4cf75f8e555_31bf3856ad364e35_6.1.7600.20942_none_c6779f3e874d1e87.manifest
File versionNot applicable
File size721
Date (UTC)13-Apr-2011
Time (UTC)18:59
PlatformNot applicable
File nameAmd64_e23c93acbf0430227b6d39e8b46e5188_31bf3856ad364e35_6.1.7600.20942_none_eefec27bbc3b767d.manifest
File versionNot applicable
File size701
Date (UTC)13-Apr-2011
Time (UTC)18:59
PlatformNot applicable
File nameAmd64_e69ece584040201e82df0c5a824d190f_31bf3856ad364e35_6.1.7601.21702_none_ab5e2a616f61306f.manifest
File versionNot applicable
File size1,042
Date (UTC)13-Apr-2011
Time (UTC)18:59
PlatformNot applicable
File nameAmd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20942_none_c8d73862e6d3eed3.manifest
File versionNot applicable
File size15,291
Date (UTC)13-Apr-2011
Time (UTC)06:24
PlatformNot applicable
File nameAmd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.21702_none_cae8d518e3d9eafb.manifest
File versionNot applicable
File size15,291
Date (UTC)13-Apr-2011
Time (UTC)07:09
PlatformNot applicable
File nameAmd64_microsoft-windows-r..gistry-trustedtypes_31bf3856ad364e35_6.1.7600.20942_none_e0a4d0556118f96d.manifest
File versionNot applicable
File size8,049
Date (UTC)13-Apr-2011
Time (UTC)06:02
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,215
Date (UTC)13-Apr-2011
Time (UTC)18:59
PlatformNot applicable
File nameX86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20942_none_6cb89cdf2e767d9d.manifest
File versionNot applicable
File size16,151
Date (UTC)13-Apr-2011
Time (UTC)05:21
PlatformNot applicable
File nameX86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7601.21702_none_6eca39952b7c79c5.manifest
File versionNot applicable
File size16,151
Date (UTC)13-Apr-2011
Time (UTC)06:37
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2534356
Revision : 3
Created on : 9/28/2018
Published on : 9/28/2018
Exists online : False
Views : 170