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FIX: The list price of a newly added variant product is set to the original list price of the product after you perform a catalog import and a category association change in Commerce Server 2009


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In Microsoft Commerce Server Catalog Manager 2009, you create a variant product by adding a variant property to a product. The list price for the variant product differs from the original list price of the product.
  • You use the Full export type format to export the catalog to an XML file.
  • You import the exported XML file into the catalog by using the Replace type format.
  • You change the category association of the product. To do that, you add and then select a category on the Category Associations tab.
In this scenario, the list price of the newly added variant product is reset to the original list price of the product.

Note The issue also occurs if you use Commerce Server APIs to perform these actions.

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Cause

The issue occurs because the exported variant product catalog XML file does not contain the original price and list price properties. When you import the catalog XML file by using the Replace type format, the original product's price properties are used to fill in the missing properties in the variant product.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Installation Notes

If you use Commerce Server 2009 Template Pack for SharePoint 2010, download and install the hotfix package that has the "CS2009TP_KB2532193" label. If you use Microsoft Commerce Server 2009 RTM, download and install the hotfix package that has the "CS2009RTM_KB2532193" label.

Prerequisites

The following list contains prerequisites for the hotfix package:
  • Microsoft Commerce Server 2009

Restart requirements

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) and the Commerce Server Catalog Import Host COM+ application after you apply this hotfix. To restart IIS, open a command prompt, type the following command, and then press Enter:
IISRESET /RESTART
Note This procedure stops and then restarts all IIS services that are running.

Replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix uses a Microsoft Windows Installer package to install the hotfix. The dates and the times for these files are listed in Coordinated Universal Time (UTC) in the following table. When you view the file information, the date is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For Microsoft Commerce Server 2009 Template Pack for SharePoint 2010
File nameFile versionFile sizeDateTimePlatform
Cspatchhelper.exe6.0.4171.51316,22412-Apr-201114:22x86
Microsoft.catalogserver.dll6.0.4171.513763,76012-Apr-201114:22x86
Microsoft.commerceserver.runtime.dll6.0.4171.513849,79212-Apr-201114:22x86
Microsoft.commerceserver.catalog.dll6.0.4171.513960,38412-Apr-201113:58x86
For Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
Cs2009hotfixhelper.exe6.0.4171.4612,13606-Apr-201112:03x86
Microsoft.catalogserver.dll6.0.4171.46763,76006-Apr-201112:03x86
Microsoft.commerceserver.runtime.dll6.0.4171.46849,79206-Apr-201112:03x86
Microsoft.commerceserver.catalog.dll6.0.4171.46960,38406-Apr-201111:42x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kb

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Article Info
Article ID : 2532193
Revision : 2
Created on : 9/26/2018
Published on : 9/26/2018
Exists online : False
Views : 267