Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The content under an NFS share root may not be listed on an NFS client when the NFS share is mounted in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Microsoft Services for Network File System (NFS) on a Windows Server 2008 R2-based server that uses the NTFS file system.
  • You export an NFS share on the server.
  • A user connects to the server and then mounts the NFS share from an NFS client.
In this scenario, the user may not see the files or the folders under the NFS share root. However, the user can access the files or the folders by using the exact path under the NFS share root.

↑ Back to the top


Cause

This problem occurs because of an issue in the NTFS file system driver.�This issue causes Services for NFS in Windows Server 2008 R2�to return an ERR_IO error to NFS clients.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, you must have Services for NFS installed. For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 0.20xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.1.7600.209691,685,88819-May- 201105:57x64
Ntfs.sys6.1.7601.217301,659,77619-May-201105:54x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.1.7600.209693,552,64019-May-201105:00IA- 64
Ntfs.sys6.1.7601.217303,553,15219-May-201104:58IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7600.20969_none_030962ad4fa65f41.manifest
File versionNot applicable
File size14,514
Date (UTC)19-May-2011
Time (UTC) 18:43
File nameAmd64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7601.21730_none_05072cdd4cbc934b.manifest
File versionNot applicable
File size14,514
Date (UTC)19-May- 2011
Time (UTC)19:18
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_microsoft-windows-ntfs_31bf3856ad364e35_6.1.7600.20969_none_a6ec6b1f9746f707.manifest
File versionNot applicable
File size14,511
Date (UTC)19-May-2011
Time (UTC)18:44
File nameIa64_microsoft-windows- ntfs_31bf3856ad364e35_6.1.7601.21730_none_a8ea354f945d2b11.manifest
File versionNot applicable
File size14,511
Date (UTC)19-May-2011
Time (UTC)19:13

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, KB2532153

↑ Back to the top

Article Info
Article ID : 2532153
Revision : 1
Created on : 6/15/2011
Published on : 6/15/2011
Exists online : False
Views : 310