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Settings groups display as Unknown after an upgrade to Dynamics CRM 2011


Symptoms

After upgrading to Microsoft Dynamics CRM 2011 from Microsoft Dynamics CRM 4.0, you may notice that the group titles within the settings section may show up as Unknown

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Cause

This issue may be caused if the SiteMap was edited to add a subarea to the main settings group in Microsoft Dynamics CRM 4.0, then the organization was upgraded to Microsoft Dynamics CRM 2011. 

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Resolution

1. Create a solution that contains the SiteMap
a. Open up the Microsoft Dynamics CRM web client
b. Click on Settings > Customizations > Solutions
c. Click on New
d. For the New Solution enter in the following details:
Display Name: Modifying Site Map
Name: ModifyingSiteMap
Publisher: Click on the lookup and check the default publisher. Click Ok
Version: 1.0

e. Click on Save
f. Click on Components then click on Client Extensions
g. Click on Add Existing > Site Map
h. Click on Save
i. Click on Export Solution
j. Click on Publish All Customizations
k. Click on Next
l. On Export System Settings, click on Next
m. For Package Type, select Unmanaged
n. Click on Export

2. Modify the SiteMap to fix the issue
a. Extract all contents from the ModifyingSiteMap_1_0.zip file
b. Right-click on customizations.xml file and Open with Notepad
c. Locate the following line:
<Group Id="Business_Setting">
d. Replace it with:
<Group Id="Business_Setting" ResourceId="Menu_Label_Business" DescriptionResourceId="Menu_Label_Business">
e. Locate the following line:
<Group Id="System_Setting">
f. Replace it with:
<Group Id="System_Setting" ResourceId="Menu_Label_System" DescriptionResourceId="Menu_Label_System">
g. Locate the following line:
<Group Id="Customizations">
h. Replace it with:
<Group Id="Customizations" ResourceId="Homepage_SystemCustomization" DescriptionResourceId="Homepage_SystemCustomization">
i. Locate the following line:
<Group Id="ProcessCenter">
j. Replace it with:
<Group Id="ProcessCenter" ResourceId="Menu_Label_ProcessCenter" DescriptionResourceId="Menu_Label_ProcessCenter">
k. Within Notepad, click on File > Save

3. Zip up all files 
a. Select the following files in Windows Explorer
[Content_Types].xml
customizations.xml
solution.xml
b. After selecting all three files, right-click on them and go to Send to > Compressed (zipped) folder
c. Name the zipped file FixedModifyingSiteMap_1_0.zip

NOTE: It is important that you ONLY select the XML files and zip the files up. If you zip up a folder and try to import it, you wil get an error stating:
The solution file is invalid. The compressed file must contain the following files at its root: solution.xml, customizations.xml, and [Content_Types].xml. Customization files exported from previous versions of Microsoft Dynamics CRM are not supported.

4. Import the modified SiteMap back into Microsoft Dynamics CRM:
a. Open the Microsoft Dynamics CRM web client
b. Click on Settings > Solutions
c. Click on Import
d. Browse and select the FixedModifyingSiteMap_1_0.zip
e. Click Next
f. Click Next
g. Click Close
h. Within the Solutions window, click on Publish All Customizations
i. Close out all Internet Explorer windows and the Microsoft Dynamics CRM for Outlook client if applicable. Then launch Microsoft Dynamics CRM again.


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More Information

This issue has been resolved in the latest update for Microsoft Dynamics CRM 2011.
To check for the most recent update available, please review the following Update Rollup information

http://support.microsoft.com/kb/2466084



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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2530358
Revision : 1
Created on : 1/7/2017
Published on : 5/9/2011
Exists online : False
Views : 99