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FIX: Files and registry keys for the installation path incorrectly disappear when you run an .msi file for a Setup project that was upgraded from Visual Studio 2008 to Visual Studio 2010 SP1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You run a Windows Installer package (.msi file) for a Microsoft Visual Studio 2008 Setup project to install the program to a certain installation path.
  • You migrate the Setup project to Microsoft Visual Studio 2010 Service Pack 1 (SP1).
  • You change the values of the Version and ProductCode properties for the Setup project.
  • You set the value of the RemovePreviousVersions property for the Setup project to True.
  • You rebuild the Setup project, and then you run the generated Windows Installer package to install the program to the same installation path.

In this scenario, the files and registry keys for the installation path incorrectly disappear.

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Cause

This issue occurs because a different hashing algorithm is used to create the Globally Unique Identifiers (GUIDs) in Visual Studio 2010 SP1.

When you install the .msi file that is created from the Visual Studio 2010 SP1 Setup project, the .msi file determines that the GUID has changed. Therefore, the .msi file removes the files and registry keys for the installation path by using the sequence of the project.

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Resolution

To resolve this issue, apply this hotfix, and then set the new BackwardCompatibleIDGeneration property to True before you build the project. 

This hotfix introduces the BackwardCompatibleIDGeneration property. By default, this property is set to False. Before you build the Setup project in Visual Studio 2010 SP1, you have to explicitly set the BackwardCompatibleIDGeneration property to True

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Visual Studio 2010 Service Pack 1 (SP1) installed. 

Restart information

You may have to restart the computer after you apply this hotfix.

We recommend that you exit any instances of Visual Studio or of applications that use the Microsoft .NET Framework before you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dpca.dll10.0.40219.311236,87222-Apr-201114:57x86
Dpdpl.dll10.0.40219.311904,52022-Apr-201114:57x86
Dpedt.dll10.0.40219.311696,13622-Apr-201114:57x86
Dpplg.dll10.0.40219.3112,606,40822-Apr-201114:57x86
Dpprj.dll10.0.40219.3111,229,64022-Apr-201114:57x86


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Workaround

To work around this issue, use one of the following methods:
  • Method 1
    Manually change all component GUIDs to Visual Studio 2008 GUIDs.
  • Method 2
    Re-sequence the RemoveExistingProducts action after the InstallInitialize action. This makes sure that older files are removed and that the new files are installed.

    Note This method does not work when you have shared components.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

If you encounter the same issue when you use Visual Studio 2010, view the article in the Microsoft Knowledge Base:
2418919  FIX: Files and registry keys for the installation path disappear unexpectedly when you install an MSI file for a Setup project that has a major upgrade from Visual Studio 2008 to Visual Studio 2010 

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixdev, kbqfe, kbfix, kbhotfixserver, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2529927
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 301