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FIX: You cannot stage marketing in Commerce Server 2007 or in Commerce Server 2009 if lots of marketing data exists


View products that this article applies to.

Symptoms

You cannot stage marketing in Microsoft Commerce Server 2007 or in Microsoft Commerce Server 2009 if lots of marketing data exists. For example, you add many promotion codes to marketing before you stage the marketing.

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Cause

This issue occurs because of a time-out error.

When you try to stage marketing, a time-out feature is set to 30 seconds in Commerce Server 2007 and in Commerce Server 2009. Therefore, a time-out error occurs if lots of marketing data exists.

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Resolution

To resolve this issue, apply the following hotfix. After you apply the following hotfix, you can configure a time-out feature in the Cssrv.exe.config file.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have one of the following installed:
  • Microsoft Commerce Server 2007 Service Pack 2 (SP2) and Microsoft SQL Server Compact 3.5 Service Pack 1 (SP1)
  • Microsoft Commerce Server 2009

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Installation Instructions

To install the hotfix for Commerce Server 2007, follow these steps. To install the hotfix for Commerce Server 2009, simply run the CommerceServer2007SP3-KB2528973-ENU.exe file.
  1. Extract the hotfix package. When you extract the hotfix package, you receive the following files:
    • CommerceServer2007SP2-KB2528973-ENU.exe
    • Hotfix.txt
  2. Install SQL Server Compact Edition (CE) 3.5 SP1.

    Note If you want to install the x64 version of SQL Server 2008 CE, you must install the x86 version before you can install the x64 version.
  3. Close the Commerce Server Staging management console, and then stop the CSS service. To stop the CSS service, open a command prompt, type the following command, and then press ENTER:
    net stop css
  4. Run the CommerceServer2007SP2-KB2528973-ENU.exe file to apply the hotfix.
  5. After the installation is complete, start the CSS service. To start the CSS service, open a command prompt, type the following command, and then press ENTER:
    net start css
Note After you install this hotfix, a new file "Csssrv.exe.config" will be created in your Staging\Bin folder. The contents of this file are as follows:
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="sqlCommandTimeoutSeconds" value="60" />
</appSettings>
</configuration>

You can specify the time-out value according to your needs. This is the duration that staging code will wait for individual database operations before it times out. The default value set by this hotfix is 60 seconds, and the default value without this hotfix installed is 30 seconds.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Commerce Server 2007 Service Pack 2
File nameFile versionFile sizeDateTimePlatform
Csssrv.exe.configNot applicable18430-Mar-201112:19Not applicable
Microsoft.commerceserver.staging.businessdatastagingframework.dll6.0.4109.61108,48031-Mar-201113:52x86
Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
Csssrv.exe.configNot applicable18430-Mar-201113:34Not applicable
Cs2009hotfixhelper.exe6.0.4171.5512,13615-Dec-201106:34x86
Microsoft.commerceserver.staging.businessdatastagingframework.dll6.0.4171.55108,48015-Dec-201106:34x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about how to stage business data, visit the following MSDN website:

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2528973
Revision : 1
Created on : 1/7/2017
Published on : 5/7/2013
Exists online : False
Views : 328