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"0x0000003B" Stop error when you remotely control a Remote Desktop session in Windows Server 2008 R2


View products that this article applies to.

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

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Symptoms

Consider the following scenario:
  • You install the Remote Desktop Session Host role on a computer that is running Windows Server 2008 R2.
  • You initiate to remotely control a Remote Desktop session, or you are remotely controlling a Remote Desktop session from another Remote Desktop session on the computer.

    Note This operation that you perform is known as "shadowing."
In this scenario, you receive a Stop error message that resembles the following:
STOP: 0x0000003B ( parameter1 , parameter2 , parameter3 , parameter4 )
The SYSTEM_SERVICE_EXCEPTION

Notes
  • Not all "0x0000003B" Stop errors are caused by this issue.
  • The parameters in this error message vary, depending on the configuration of the computer.

Information for developers

This issue occurs when both of the following actions are performed at the same time in a Remote Desktop session:
  • An application or service calls the EnumDisplaySettings function.
  • You initiate to remotely control another Remote Desktop session, or you are remotely controlling another Remote Desktop session.

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Cause

This issue occurs because the Remote Desktop Protocol (RDP) display driver (Rdpdd.sys) does not check whether an object is NULL before Rdpdd.sys accesses the object. Therefore, this issue occurs when Rdpdd.sys accesses an object that has a NULL value.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Additionally, the Remote Desktop Services role service must be installed.

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    20xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatformService branch
Rdpwd.sys6.1.7600.20928205,82419-Mar-201105:44x64Not applicable
Rdpdd.dll6.1.7600.20928194,56019-Mar-201105:43x64AMD64_MICROSOFT-WINDOWS-T..S-RDP-DISPLAYDRIVER_31BF3856AD364E35_6.1.7600.20928_NONE_414E4D4987942D3F
Rdpdd.dll6.1.7601.21687274,94419-Mar-201105:42x64AMD64_MICROSOFT-WINDOWS-T..S-RDP-DISPLAYDRIVER_31BF3856AD364E35_6.1.7601.21687_NONE_42F2C89784EC2A53

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Workaround

Workaround for Windows Server 2008 R2

To work around this issue, do not call the EnumDisplaySettings function when the operation that remotely controls the Remote Desktop session is active.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the EnumDisplaySettings function, visit the following MSDN website:

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_1f7ffed2870e4badb2f02a9a7844fb0e_31bf3856ad364e35_6.1.7601.21687_none_0955ba9cb4058cdd.manifest
File versionNot applicable
File size726
Date (UTC)21-Mar-2011
Time (UTC)19:10
PlatformNot applicable
File nameAmd64_b62498c026920813a651bb4f7f102628_31bf3856ad364e35_6.1.7600.20928_none_1f25f96ec90adb6e.manifest
File versionNot applicable
File size1,097
Date (UTC)21-Mar-2011
Time (UTC)19:10
PlatformNot applicable
File nameAmd64_microsoft-windows-t..dp-winstationdriver_31bf3856ad364e35_6.1.7600.20928_none_a838009e079dc4ed.manifest
File versionNot applicable
File size3,435
Date (UTC)19-Mar-2011
Time (UTC)08:19
PlatformNot applicable
File nameAmd64_microsoft-windows-t..s-rdp-displaydriver_31bf3856ad364e35_6.1.7600.20928_none_414e4d4987942d3f.manifest
File versionNot applicable
File size2,816
Date (UTC)19-Mar-2011
Time (UTC)08:30
PlatformNot applicable
File nameAmd64_microsoft-windows-t..s-rdp-displaydriver_31bf3856ad364e35_6.1.7601.21687_none_42f2c89784ec2a53.manifest
File versionNot applicable
File size2,816
Date (UTC)19-Mar-2011
Time (UTC)08:19
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,762
Date (UTC)21-Mar-2011
Time (UTC)19:10
PlatformNot applicable

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Keywords: kb, kbmdd, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbexpertiseinter, kbsurveynew

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Article Info
Article ID : 2525246
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 191