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Imagex.exe cannot capture an image in Windows PE 3.0 on a computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2 and that has multiple processors.
  • You run the Imagex.exe tool to capture an image in Windows Preinstallation Environment (Windows PE) 3.0 on the computer.
In this scenario, Imagex.exe randomly fails. Additionally, you may receive one of the following error messages:
The process cannot access the file because it is being used by another process.


The instruction at memory address referenced memory at memory address. The memory could not be write. Click OK to terminate the program.

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Cause

This issue occurs because of a timing issue in the Imagex.exe tool.

When the timing issue occurs, two threads try to open a file at the same time. Therefore, you receive the error message that is mentioned in the "Symptoms" section.

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Resolution

To resolve this issue, install the latest version of Windows Assessment and Deployment Kit (Windows ADK), or install the hotfix package that is described in the "Hotfix information" section.

Method 1: Install Windows ADK

  1. Download the latest version of Windows ADK.
  2. Mount the problematic Winpe.wim file by using the Imagex.exe tool together with the /mountrw syntax. To do this, run the following command at a command prompt:
    IMAGEX.EXE /mountrw Path of the Winpe.wim 1 Staging area
  3. Copy the updated imagex file (by default, it is located at C:\Program Files (x86)\Windows Kits\8.1\Assessment and Deployment Kit\Deployment Tools\amd64\DISM\Imagex.exe) to the Tools directory of the mounted Winpe.wim file.
  4. Unmount the Winpe.wim file by using the Imagex.exe tool together with the /commit syntax. To do this, run the following command at a command prompt:
    IMAGEX.EXE /commit

Method 2: Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Installation instructions

For users who have already installed Win7 RTM OPK or WAIK tool Kit:

This download provides updated version of imagex.exe file that replace the imagex.exe file on system. By default, ImageX is installed in the following folder:

WAIK users:
C:\Program Files\Windows AIK\Tools\<architecture>

OPK Users:
C:\Program Files\Windows OPK\Tools\<architecture>
Note: <architecture> is x86 or amd64 or IA64.

To update imagex.exe, follow these steps:
1. Download the ImageX release .cab file for all architectures to a folder on your computer.
2. In Windows Explorer, locate the x86 .cab file on your computer.
3. In Windows Explorer, double-click the .cab file to view the contents of the file.
4. Press CTRL+A to select imagex.exe.
5. Right-click the selection, and then click Extract.
6. In the Select a Destination window, select the folder that contains the .cab file.
7. Click Make New Folder, and then type x86 for the folder name.
8. Click Extract to extract the files.
9. In Windows Explorer, locate the folder where you extracted the files in the previous steps.
10. Press CTRL+A to select ImageX in the folder.
11. Right-click the selection, and then click Copy.
12. Locate the folder where the x86 imagex.exe file is installed on your computer. For example, the x86 imagex.exe file may be installed in the C:\Program Files\Windows AIK\Tools\x86 or C:\Program Files\Windows OPK\Tools\x86 folder as per WAIK or OPK users.
13. Right-click anywhere in the folder, and then click Paste.
14. When you are prompted, click Copy and Replace to replace the imagex.exe file with the newer version that this release includes.
15. If a window prompts you for administrator permissions, click Continue. If other File Operation windows prompt you, click yes in those windows.
16. Repeat steps 2-15 by using the amd64 ImageX .cab file, by typing amd64 for the folder name, and by selecting this folder as the destination for the extracted amd64 ImageX file. For example, the amd64 imagex.exe file may be installed in the C:\Program Files\Windows AIK\Tools\amd64 OR C:\Program Files\Windows OPK\Tools\amd64 folder as per WAIK or OPK users.
17. Repeat steps 2-15 by using the IA64 ImageX .cab file, by typing IA64 for the folder name, and by selecting this folder as the destination for the extracted IA64 ImageX file. For example, the amd64 imagex.exe file may be installed in the C:\Program Files\Windows AIK\Tools\IA64 OR C:\Program Files\Windows OPK\Tools\IA64 folder as per WAIK or OPK users.

For users who are using imagex.exe as standalone executable, follow these steps:
  1. Manually extract this hotfix package to a temporary location.
  2. Mount the problematic Winpe.wim file by using the Imagex.exe tool together with the /mountrw syntax. To do this, run the following command at a command prompt:
    IMAGEX.EXE /mountrw Path of the Winpe.wim 1 Staging area
  3. Copy the updated imagex file to the Tools directory of the mounted Winpe.wim file.
  4. Unmount the Winpe.wim file by using the Imagex.exe tool together with the /commit syntax. To do this, run the following command at a command prompt:
    IMAGEX.EXE /commit

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760 1. 21xxxWindows 7 and Windows Server 2008 R2SP1LDR
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Imagex.exe6.1.7601.21716475,64828-Apr-201102:34x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Imagex.exe6.1.7601.21716574,97628-Apr-201102:51x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Imagex.exe6.1.7601.217161,188,35228-Apr-201102:12IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the ImageX tool, visit the following TechNet website:

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Keywords: consumerwin7track, kbqfe, kbfix, kbhotfixserver, kbautohotfix, kbsurveynew, kbexpertiseinter, atdownload, kb

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Article Info
Article ID : 2525084
Revision : 1
Created on : 1/7/2017
Published on : 7/9/2015
Exists online : False
Views : 279