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The user principal names (UPN), email addresses, or proxy addresses of users contain an Office 365 domain after synchronization


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Symptoms

Consider the following scenario. You use the Microsoft Online Services Directory Synchronization Tool to synchronize your local Active Directory Domain Services to Microsoft Office 365. However, after synchronization, the user principal names (UPN), email addresses, or proxy addresses of users contain the domain that is assigned to your company when you signed up for Office 365 instead of your company domain. For example, the email address of a user is as follows:
UserName@contoso.onmicrosoft.com

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Cause

This behavior occurs if your company's domain is not added to and verified in Office 365 before you start and enable directory synchronization. If you start and enable directory synchronization before you add and verify your domain, user accounts are synchronized. In this case, Office 365 assigns users a third-level Office 365 domain. For example, it assigns the following domain:
contoso.onmicrosoft.com
And after the domain is verified, the UPN of the user is changed accordingly.

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Resolution

We strongly recommended that you add and verify your domain in the Office 365 portal or by using the Microsoft Online Services Module for Windows PowerShell�before you start and enable directory synchronization. �

Make sure that users are synchronized from the on-premises environment to Office 365 by using the same UPNs and email addresses. All domains that are associated with users' UPN, email addresses, and proxy addresses must be verified in your Office 365 subscription.

For example, if the on-premises UPN of a user is user@contoso.com, and the user's default email address is user@fabrikam.com, make sure that both the contoso.com domain and the fabrikam.com domain are verified.

Note the following scenarios:
  • If the user does not yet have a license, and the domain is verified, the UPN is changed accordingly.
  • If the user has a license, and the domain is verified, the following conditions occur:
    • The UPN does not change for non-federated users.
    • The UPN is changed for federated users.
    • The default email addresses are changed accordingly.
    • Alternative email addresses that use the verified domain are automatically added.
To update a non-federated user's UPN while they have a license, follow these steps:

  1. Connect to Microsoft Online Services PowerShell via Microsoft Online Services Module for Windows PowerShell
  2. Run the following PowerShell cmdlet:
    Set-MsolUserPrincipalName -UserPrincipalName [CurrentUPN] -NewUserPrincipalName [NewUPN]

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More information

For more information about how to add and verify a domain in Office 365, visit the following Microsoft website:

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Keywords: KB2523192, vkbportal230, vkbportal237, o365, bposs, vkbportal231

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Article Info
Article ID : 2523192
Revision : 17
Created on : 7/14/2011
Published on : 7/14/2011
Exists online : False
Views : 3612