Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Visual Studio IDE responds slowly when you press Enter or make an edit in a code file of a large VB project in Visual Studio 2010


View products that this article applies to.

Symptoms

When you press Enter or make an edit in a code file of a large Visual Basic project in Microsoft Visual Studio 2010, Visual Studio Integrated Development Environment (IDE) responds slowly. 

For example, the IDE does not respond for 5-12 seconds after you press Enter.

↑ Back to the top


Cause

This issue occurs because of an error in the Visual Basic compiler.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


Prerequisites

To apply this hotfix, you must have Visual Studio 2010 Service Pack 1 (SP1) installed.  

Restart requirement

You must restart the computer after you apply this hotfix if the affected file is being used.
We recommended that you close all instances of Visual Studio before you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File Information

The version of this has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File nameFile versionFile sizeDateTimePlatform
Msvbide.dll10.0.40219.3055,555,53628-Mar-201114:23x86
Vbdebug.dll10.0.40219.3052,955,60028-Mar-201114:23x86
Vbdebug.dll10.0.40219.3053,923,79228-Mar-201114:23x64
Vbdebug.dll10.0.40219.3057,805,26428-Mar-201114:23IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbhotfixdev, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2522841
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 166