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CM Transaction type for an Increase Adjustment incorrectly changed to Cheque (CHQ) after selecting Void Transaction in Bank Reconciliation for Microsoft Dynamics GP


Symptoms

If a posted increase adjustment transaction is pulled up in the Bank Transaction Entry window (by typing in the Chequebook ID and the number) with the Option as Void Transaction and then the window is closed instead of posting the void or the Clear button is used, rather than voiding the selected transaction, then this transaction is changed from 'Increase Adjustment' (IAJ) to Cheque (CHQ).

Note This behavior is seen only when the Checkbook ID and Number fields are manually typed in the Bank Transaction window, instead of selecting them from the Lookup button.

Furthermore, in the Chequebook Balance Inquiry window, the amount for this transaction appears in the Payment column, instead of the Deposit column, which makes the balance on the particular transaction appear incorrect since the Balance field in this inquiry window is dynamically calculated. The window will treat the amount as a decrease to the balance instead of an increase. (However, the actual Current Chequebook Balance is correct.)

When the type of the transaction is changed from IAJ (Increase adjustment) to CHQ (Cheque), the systems sees it as a cheque now and if it is voided, the chequebook balance will be incorrectly increased instead of decreased.

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Cause

When a transaction type other than Cheque is selected for voiding in the Bank Transaction Entry window and the Clear button is used, or the window is closed rather than voiding the selected transaction, the Transaction Type is changed to a type of Cheque (CHQ) in the CM20200 table, if the Transaction Number was manually entered in the Number field of the Bank Transaction Entry window, instead of selecting it from the Lookup button. If the lookup is used to locate the transaction, then the Transaction Type is not updated when the window is closed or the Clear button is used. This makes the Balance appear incorrect in the Checkbook Inquiry window.

Note: This issue only occurs when Canadian Payroll is installed in a Canadian GP installation. This is logged as CR #8627.

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Resolution

This issue only happens when you manually type in the Chequebook ID or Number in the Bank Transactions window. Therefore, to work around this issue, do not type in the Transaction Number and instead, use the Lookup button (magnifying glass) to select the Chequebook ID and Transaction Number from the list. 

Do not void the transaction after the IAJ type has changed to CHQ or the chequebook balance will be incorrected increased. Depending on what type of transaction it was, you may be able to just update the Transaction Type (CMTRXTYPE) directly in the CM20200 table before voiding it, but that should be tested in a test environment first. If further assistance is needed with this issue, you may open a case with Microsoft Dynamics GP Support and refer to CR #8627.



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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2522239
Revision : 1
Created on : 1/7/2017
Published on : 8/5/2011
Exists online : False
Views : 90