Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Exchange System Manager Does Not Verify Smart Host DNS Names


View products that this article applies to.

Symptoms

Messages may be queued in an SMTP connector queue awaiting delivery to a smart host. If the smart host name is not valid, these messages are not delivered. In certain cases, it may not be readily apparent that the smart host name is not a valid name, for example if the smart host name includes leading or trailing spaces.

↑ Back to the top


Cause

When you configure an SMTP connector in Exchange System Manager, it is possible to enter a smart host name that is not a valid Domain Name System (DNS) host name or one that contains invalid characters. For example, Exchange System Manager does not truncate leading or trailing spaces.

Exchange System Manager does not check the smart host field to see if it is a valid or reachable host name. This allows you to configure a connector to deliver to a smart host that is not currently reachable.

↑ Back to the top


Resolution

Verify that the name of the smart host on the General tab of the connector properties is valid, and does not contain leading or trailing spaces.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

↑ Back to the top


Keywords: KB251951, kbpending, kbbug

↑ Back to the top

Article Info
Article ID : 251951
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 387