Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: Cannot Perform Backup When Exchange System Manager Is Not Installed


View products that this article applies to.

Symptoms

When you try to perform a backup for a computer running Microsoft Exchange 2000 Server on which the Exchange Server Services are installed but the Exchange System Manager is not, the backup may fail to start or may return an error message, depending on the backup software involved.

↑ Back to the top


Cause

This behavior occurs because upon installation, both the Exchange Server Services and Exchange System Manager install files and make changes to the registry that are necessary for a successful backup. When Exchange System Manager is not installed, some of the needed files and registry settings are missing, and the backup fails.

↑ Back to the top


Resolution

Install Exchange System Manager on the server; doing so installs the proper files and adds the registry keys needed for a successful backup.

↑ Back to the top


Workaround

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

The following workaround enables a backup to complete without installing Exchange System Manager:
  1. Copy the Esebcli2.dll file from the Exchange 2000 CD to the Exchsrvr\Bin folder.
  2. Add the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\DLLPaths
  3. Add the following value:
    esebcli2 = c:\exchsrvr\bin\esebcli2.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

↑ Back to the top


Keywords: KB251904, kbnofix, kbbug

↑ Back to the top

Article Info
Article ID : 251904
Revision : 5
Created on : 2/22/2007
Published on : 2/22/2007
Exists online : False
Views : 278