Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Values in the ChannelConfiguration.config file are lost after you deactivate the Commerce Server Channel Configuration feature on a Commerce Server 2009 website


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a Microsoft Commerce Server 2009 website that uses Commerce Web Parts.
  • You deploy the website to a SharePoint server by using SharePoint Commerce Services Configuration Wizard.
  • You configure some values in the ChannelConfiguration.config file of the website.
  • You click Site Actions - > Site Settings - >Manage Site Features, and then you click Deactivate to deactivate the Commerce Server Channel Configuration feature.
In this scenario, the values that you configured in the ChannelConfiguration.config file are lost.

↑ Back to the top


Cause

This issue occurs because of an error in Commerce Server 2009 Web Parts.

↑ Back to the top


Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have Microsoft Commerce Server 2009 or Microsoft Commerce Server 2009 Template Pack for SharePoint 2010 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) and the Commerce Server Catalog Import Host COM+ application after you apply this hotfix.

To restart IIS, type the following command at a command prompt, and then press ENTER:
IISRESET /RESTART
Note This command stops and then restarts all IIS services that are running on a computer.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Installation steps

If you use Microsoft Commerce Server 2009 together with SharePoint Server 2010, download and install the hotfix package that has the "CS2009TP_KB2516181" label. If you use Microsoft Commerce Server 2009 RTM together with SharePoint Server 2007, download and install the hotfix package that has the "CS2009RTM_KB2516181" label. These two hotfix packages contain the following files and a source folder that has the ChannelConfigurationFeatureReceiver.cs file:
  • For the "CS2009TP_KB2516181" hotfix package:
    • Cs2009tp-kb2516181-x86.exe
    • Hotfix.txt
  • For the "CS2009RTM_KB2516181" hotfix package:
    • Commerceserver2007sp3-kb2516181-enu.exe
    • Cs2009-kb2516181-x86.exe
    • Hotfix.txt
Notes
  • The installation file that you have to install depends on the version of SharePoint on the computer that is running Commerce Server.
  • You must use the local administrator account when you install this hotfix, or you must run the hotfix by using the Run as Administrator option. If you are running Windows Vista, Windows Server 2008, or a later operating system, and if User Account Control (UAC) is enabled, we recommend that you use the Run as Administrator option.
After you run the installation files, use the method that is described for one of the following situations:
  • Situation 1

    If no sites are deployed, run SharePoint Commerce Services Configuration Wizard to deploy the new site by using the updated MicrosoftCommerceWebParts.WSP solution file.
  • Situation 2

    If some sites are deployed, deploy the updated Web solution package (WSP) file by using the following stsadm command:
    stsadm -o upgradesolution -name microsoftcommercewebparts.wsp -filename MicrosoftCommerceWebParts.WSP -immediate -allowgacdeployment
  • Situation 3

    If Web Parts are customized by using the CommerceSharePointExtensibilityKit tool, follow these steps:
    1. Locate the updated source ChannelConfigurationFeatureReceiver.cs file in the source folder that is contained in this hotfix package.
    2. Use this source file to replace the ChannelConfigurationFeatureReceiver.cs file that is in the CommerceSharePointExtensibilityKit folder.
    3. Compile the assemblies for the Web Parts.
    4. Deploy the new MicrosoftCommerceWebParts.WSP file.


File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft Commerce Server 2009 Template Pack for SharePoint 2010

File nameFile versionFile sizeDateTimePlatform
Channelconfigurationfeaturereceiver.csNot Applicable11,21716-Mar-201106:32Not Applicable
microsoftcommercewebparts.wspNot applicable707,78502-Mar-201121:26Not applicable
Microsoft Commerce Server 2009 RTM

File nameFile versionFile sizeDateTimePlatform
microsoftcommercewebparts.wspNot applicable699,65703-Mar-201121:44Not applicable
Microsoft.commerce.providers.dll1.0.20123.31690,04003-Mar-201121:16x86
Cs2009hotfixhelper.exe6.0.4171.4013,08003-Mar-201113:19x86
Microsoft.catalogserver.dll6.0.4171.40756,52003-Mar-201113:19x86
Microsoft.commerceserver.runtime.dll6.0.4171.40850,74403-Mar-201113:19x86
Microsoft.commerceserver.catalog.dll6.0.4171.40961,33603-Mar-201113:08x86
Channelconfigurationfeaturereceiver.csNot Applicable11,21016-Mar-201103:55Not Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

For more information about how to use the Channel Configuration feature, visit the following MSDN website:For more information about Commerce Foundation Channel Configuration, visit the following MSDN website:

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2516181
Revision : 1
Created on : 1/7/2017
Published on : 3/31/2011
Exists online : False
Views : 310