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An error occurs when closing Opportunites in Microsoft Dynamics CRM


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Symptoms

When closing an Opportunity in Microsoft Dynamics CRM, one of the following errors may occur:

1. "An error has occurred"

Or

2. "Invalid User Authorization"



Tracing with Dev Errors may display the following:

Stack Trace Info: [NullReferenceException: Object reference not set to an instance of an object.]
   at Microsoft.Crm.Dialogs.CloseOppPage.ConfigureForm()
   at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

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Cause

The Topic field is not populated. This is a required field for closing the Opportunity.

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Resolution

Enter data in the Topic field in the Opportunity.

Verify if the Topic field has been populated with the following steps:


In Microsoft Dynamics CRM 4.0:

1. Click Settings, click Customization, click Customize Entities

2. Open the Opportunity Entity

3. Click Attributes

4. Under the Name column, find Name

5. This can be made a required field if this Attribute is opened and Business Required from the Requirement Level drop down is selected.




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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2514234
Revision : 1
Created on : 1/7/2017
Published on : 9/14/2012
Exists online : False
Views : 262