Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Windows Server 2003 TS Licensing server does not renew new versions of TS Per Device CALs or RDS Per Device CALs that are expired


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2003 and that has Terminal Server enabled.
  • You configure the terminal server to contact a Windows Server 2003-based Terminal Services (TS) Licensing server to request or renew Terminal Server client access licenses (TS CALs).
  • You try to create a terminal server session from a client computer to the terminal server. The client computer has an expired Windows Server 2008 TS Per Device CAL or an expired Windows Server 2008 R2 RDS Per Device CAL.
In this scenario, the terminal server session fails, and you receive the following error message:
The remote session was disconnected because there were no terminal server license server available to provide a License.

↑ Back to the top


Cause

This issue occurs because the Windows Server 2003-based license server does not recognize new versions of TS Per Device CALs or of Remote Desktop Services Per Device client access licenses (RDS CALs). Therefore, the license server does not respond to the request or renew the CAL.

↑ Back to the top


Resolution

To resolve this issue, install the following hotfix on the Windows Server 2003-based TS Licensing server.

Note The following hotfix package replaces hotfix 2276913. After you install hotfix 2276913, a Windows Server 2003-based TS Licensing server can renew permanent Windows Server 2008 TS Per Device CALs or Windows Server 2008 R2 RDS Per Device CALs that are expired. However, the Windows Server 2003-based TS Licensing server cannot renew temporary Windows Server 2008 TS Per Device CALs or Windows Server 2008 R2 RDS Per Device CALs that are expired. The following hotfix lets the Windows Server 2003-based TS Licensing server renew expired Windows Server 2008 TS Per Device CALs or Windows Server 2008 R2 RDS Per Device CALs that are permanent or temporary.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).
Additionally, Terminal Services Licensing component must be installed.

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You can avoid restarting the computer if you stop the Terminal Services Licensing service before you install the hotfix package. You have to start the Terminal Services Licensing service after you install the hotfix package.

Hotfix replacement information


This hotfix replaces a previously released hotfix 2276913. For more information, click the following article number to view the article in the Microsoft Knowledge Base: replace a previously released hotfix.
2276913 A Windows Server 2003-based TS Licensing server does not renew new versions of TS Per Device CALs or of RDS Per Device CALs when the CALs expire

File information

The English version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Lserver.exe5.2.3790.4834349,69621-Feb-201113:17x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Lserver.exe5.2.3790.4834538,11222-Feb-201105:09x64
For all supported IA-64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Lserver.exe5.2.3790.4834995,32822-Feb-201105:09IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about TS Licensing, visit the following Microsoft webpage.

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, kbautohotfix, KB2512845

↑ Back to the top

Article Info
Article ID : 2512845
Revision : 4
Created on : 12/27/2012
Published on : 12/27/2012
Exists online : False
Views : 335