Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Cluster Server cannot start if the Quorum disk space is full


Symptoms

You may be unable to start Windows Clustering. Also, any combination of the following event messages may be listed in the System Event log:

  • Event 1021: There is insufficient disk space remaining on the Quorum device. Please free up some space on the Quorum device. If there is no space on the disk for the Quorum Log files, then changes to the cluster registry will be prevented.
  • Event 1080: Microsoft Cluster Server could not write file file. The disk may be low on disk space or some other serious condition exists.
  • Event 1016: Microsoft Cluster Server failed to obtain a checkpoint from the cluster database for log file file.
  • Event 1000: Microsoft Cluster Server suffered an unexpected fatal error at line line of source module module. The error code was: 112.
  • Event 1022: There is insufficient space left on the Quorum device. Microsoft Cluster Server cannot start.
  • Event 1009: Microsoft Cluster Server could not join an existing cluster and could not form a new cluster. Microsoft Cluster Server has terminated.
  • Event 1063: Microsoft Cluster Server was successfully stopped.

↑ Back to the top


Cause

This behavior can occur if the disk that contains the Quorum log file does not have any free disk space.

↑ Back to the top


Resolution

To resolve this issue, follow these steps:
  1. Shut down all cluster nodes except one.
  2. On the remaining node, click Start, click Windows Administrative Tools or Administrative Tools, and then click Computer Management.
  3. Click Device Manager, and then click Show Hidden Devices on the View menu.
  4. In the right pane, expand System Devices, and then double-click the Cluster Disk Driver.
  5. On the Driver tab, click Disable, click Yes when prompted, and then click OK.
  6. Expand Services and Applications and click Services.
  7. In the right pane, double-click the Cluster Service, and then click Disabled in the Startup type box.
  8. Restart the node. Because the Cluster Disk driver does not start, the disk drives on the shared SCSI bus appear as standard disk drives to the computer.
  9. Carefully delete any unneeded files on the Quorum disk to free space on the disk drive. Do not access any files that might be required by the Cluster service or by shared applications unless it is necessary.
  10. Reenable the Cluster Disk Driver in Device Manager, and set the Cluster Service startup type back to Automatic.
  11. Restart the computer. The Cluster Service should start and the shared SCSI disk drives and all other resources should be "owned" by this node.
  12. Restart the other nodes. If it is necessary, you can now move the Quorum disk to a disk that has more available free space.

↑ Back to the top


Status

This behavior is by design.

↑ Back to the top


More Information

If the Cluster Service on both nodes has stopped, it may be impossible to start the Cluster Service on either node. Until the Cluster Service is started, neither node can "own" the disk drive that contains the Quorum log file. Because neither node can "own" the disk drive, access to the disk drive is not available and therefore files on the disk drive cannot be deleted.

↑ Back to the top


Keywords: kbnetwork, kbprb, kbbillprodsweep, kb

↑ Back to the top

Article Info
Article ID : 251284
Revision : 6
Created on : 4/20/2018
Published on : 4/20/2018
Exists online : False
Views : 202