Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive the following error message in Microsoft Dynamics GP when you delete or post a transaction that has an Extender window associated with the transaction: “Could not run file trigger script”


Symptoms

If you have an Extender window linked to a transaction window and you delete the transaction or post the transaction, you receive the following error message in Microsoft Dynamics GP:

Error 1:

Unhandled script exception:
Invalid data for string operation: 26.


EXCEPTION_CLASS_SCRIPT_BAD_TYPE
SCRIPT_CMD_ADD

Error 2:

Could not run file trigger script.

↑ Back to the top


Cause

This issue occurs because there is a Work table link that is linked to the Extender Window. We do not recommended that you use Work tables with an Extender Table Link because if the transaction is posted, the Extender data will be deleted.  

↑ Back to the top


Resolution

To resolve these errors, go into Microsoft Dynamics GP and follow these steps.

1. Click Tools, click Extender, and then click Extender.

2. In the Extender Object area, click Window, and then click the Extender window in which is linked to your transaction window that you are receiving the error.

3. In the Extender Window, click the Options menu.

4. Select Table Links.

5. In the Table Links window, select the work table in the Table Links section.

6. Click the Remove Selected Table Link icon, the - icon.

7. Select Delete to remove the Table Link.

8. Click Save in the Extender Windows.

9. Exit Dynamics GP and start back into Dynamics GP.

10. Delete your transaction.

↑ Back to the top


More Information

If you still receive the “Could not run file trigger script” check the EXT44200 and EXT44300 tables for your Extender Window ID. Run the following SQL script (Replace XXX with your Extender Window ID) to verify that your Extender Window does not exist in the tables:

select * from EXT44200 where Extender_ID = 'XXX'

select * from EXT44300 where Extender_ID = 'XXX'

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2508025
Revision : 1
Created on : 1/7/2017
Published on : 8/5/2011
Exists online : False
Views : 94