Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A call is disconnected when transferring the call from the main auto attendant to an auto attendant that has a different language configured in an Exchange Server 2010 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install two or more Unified Messaging (UM) language packs on a Microsoft Exchange Server 2010 UM server.
  • You create a main auto attendant, and then you create and configure other auto attendants that support other languages.
  • You configure the main auto attendant to have appropriate key mappings to access other auto attendants.
  • The main auto attendant receives an incoming call. Then, the caller presses a key to transfer the call to an auto attendant with a different language configured.
In this scenario, the caller hears an error message in the selected language, and the call is disconnected. Additionally, the UM worker process (UMWorkerProcess.exe) crashes.

↑ Back to the top


Cause

This issue occurs because the speech recognition engine of the language does not change.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2529939 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 1

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about UM auto attendants, visit the following Microsoft website:For more information about how to configure key mapping entries on a UM auto attendant, visit the following Microsoft website:

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbhotfixrollup, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2506998
Revision : 1
Created on : 1/7/2017
Published on : 4/6/2011
Exists online : False
Views : 298