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You experience slow performance when you run the Aged Accounts Receivable report (120) or the Aged Accounts Payable report (332) in the RoleTailored client in Microsoft Dynamics NAV 2009


View products that this article applies to.

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

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Symptoms

When you run the Aged Accounts Receivable report (120) or the Aged Accounts Payable report (322) in the RoleTailored client (RTC) in Microsoft Dynamics NAV 2009, you experience slow performance. Additionally, in some scenarios, the client crashes and you receive the following error message:
OutOfMemory Exception.

This problem occurs in the following products:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)

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Cause

This problem occurs because large volume of data is sent to the RTC. The data is much more than what is actually printed.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics NAV service pack or the next Microsoft Dynamics NAV version that contains this hotfix.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

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Installation information

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

Note Before you install this hotfix, verify that all Microsoft Navision client users are logged off the system. This includes Microsoft Navision Application Services (NAS) client users. You should be the only client user who is logged on when you implement this hotfix.

To implement this hotfix, you must have a developer license.

We recommend that the user account in the Windows Logins window or in the Database Logins window be assigned the "SUPER" role ID. If the user account cannot be assigned the "SUPER" role ID, you must verify that the user account has the following permissions:
  • The Modify permission for the object that you will be changing.
  • The Execute permission for the System Object ID 5210 object and for the System Object ID 9015 object.


Note You do not have to have rights to the data stores unless you have to perform data repair.

Code changes

Note Always test code fixes in a controlled environment before you apply the fixes to your production computers.
To resolve this problem, follow these steps:
  1. Change the code in the OpenCustLedgEntry - OnAfterGetRecord trigger in the Aged Accounts Receivable report (120) as follows:
    Existing code
    ...
    IF AgingBy = AgingBy::"Posting Date" THEN BEGIN
    CALCFIELDS("Remaining Amt. (LCY)");
    IF "Remaining Amt. (LCY)" = 0 THEN
    CurrReport.SKIP;
    END;
    InsertTemp(OpenCustLedgEntry);
    ...
    Replacement code
    ...
    IF AgingBy = AgingBy::"Posting Date" THEN BEGIN
    CALCFIELDS("Remaining Amt. (LCY)");
    IF "Remaining Amt. (LCY)" = 0 THEN
    CurrReport.SKIP;
    END;
    InsertTemp(OpenCustLedgEntry);

    // Add the following line.
    currReport.SKIP;
    ...
  2. Change the code in the Cust. Ledger Entry - OnAfterGetRecordtrigger in the Aged Accounts Receivable report (120) as follows:
    Existing code
    ...
    IF CustLedgEntry.FINDSET(FALSE,FALSE) THEN
    REPEAT
    InsertTemp(CustLedgEntry);
    UNTIL CustLedgEntry.NEXT = 0;
    ...
    Replacement code
    ...
    IF CustLedgEntry.FINDSET(FALSE,FALSE) THEN
    REPEAT
    InsertTemp(CustLedgEntry);
    UNTIL CustLedgEntry.NEXT = 0;

    // Add the following line.
    CurrReport.SKIP;
    ...
  3. Change the code in the TempCustLedgEntryLoop - OnAfterGetRecord trigger in the Aged Accounts Receivable report (120) as follows:
    Existing code
    ...
    IF PrintToExcel THEN
    MakeExcelDataBody;
    ...
    Replacement code
    ...
    IF PrintToExcel THEN
    MakeExcelDataBody;

    // Add the following line.
    If NOT PrintDetails then CurrReport.SKIP
    ...
  4. Change the code in the Vendor Ledger Entry - OnAfterGetRecord trigger in the Aged Accounts Payable report (322) as follows:
    Existing code
    ...
    IF VendorLedgEntry.FINDSET(FALSE,FALSE) THEN
    REPEAT
    InsertTemp(VendorLedgEntry);
    UNTIL VendorLedgEntry.NEXT = 0;
    ...
    Replacement code
    ...
    IF VendorLedgEntry.FINDSET(FALSE,FALSE) THEN
    REPEAT
    InsertTemp(VendorLedgEntry);
    UNTIL VendorLedgEntry.NEXT = 0;

    // Add the following line.
    CurrReport.SKIP;
    ...
  5. Change the code in the OpenVendorLedgEntry - OnAfterGetRecord trigger in the Aged Accounts Payable report (322) as follows:
    Existing code
    ...
    InsertTemp(OpenVendorLedgEntry);
    ...
    Replacement code
    ...
    InsertTemp(OpenVendorLedgEntry);

    // Add the folloiwng line.
    CurrReport.SKIP;
    ...
  6. Change the code in the TempVendortLedgEntryLoop - OnAfterGetRecord trigger in the Aged Accounts Payable report (322) as follows:
    Existing code
    ...
    TotalVendorLedgEntry[1]."Amount (LCY)" += VendorLedgEntryEndingDate."Remaining Amt. (LCY)";
    GrandTotalVendorLedgEntry[1]."Amount (LCY)" += VendorLedgEntryEndingDate."Remaining Amt. (LCY)";
    ...
    Replacement code
    ...
    TotalVendorLedgEntry[1]."Amount (LCY)" += VendorLedgEntryEndingDate."Remaining Amt. (LCY)";
    GrandTotalVendorLedgEntry[1]."Amount (LCY)" += VendorLedgEntryEndingDate."Remaining Amt. (LCY)";

    // Add the following line.
    If NOT PrintDetails then currreport.SKIP;
    ...

Prerequisites

You must have one of the following products installed to apply this hotfix:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)

Removal information

You cannot remove this hotfix.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Keywords: kberrmsg, kbmbscodefix, kbnoloc, kbsurveynew, kbqfe, kbmbspartner, kbmbsquickpub, kb, kbmbsmigrate

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Article Info
Article ID : 2506751
Revision : 1
Created on : 1/7/2017
Published on : 4/2/2013
Exists online : False
Views : 172