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Error message when you use Electronic Reconcile in Bank Reconciliation for Microsoft Dynamics GP "Bank Account Number from text file could not be matched to a Checkbook Account Number"


Symptoms

When you try to download the text file from the bank using Electronic Reconcile in Bank Reconciliation in Microsoft Dynamics GP, you receive the following error message:

Bank Account Number from text file could not be matched to a Checkbook Account Number



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Cause

(1) The bank account number has the leading zeroes stripped off, so it does not match between the text file and the bank account number assigned in the Checkbook Maintenance window. To resolve this problem, see Resolution 1 in the Resolution area. 

(2) The same bank account number is assigned to more than one checkbook, so the system does not know which Checkbook ID to match. To resolve this problem, see Resolution 2 in the Resolution area. 

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Resolution

Resolution 1  

Review the bank account number in the text file to make sure it matches the Bank Account Number assigned to the checkbook. Make sure the leading zeroes were not stripped off.

1. To open the Checkbook Maintenance window, click on Cards, point to Financial and click on Checkbook.

2. Select the appropriate Checkbook ID and compare the Bank Account field against the bank account number in the text file from the bank.


Resolution 2  

Compare the Bank Account numbers assigned to all the checkbooks to make sure it is not assigned to more than one checkbook, even if it is inactive. To do this, follow these steps:

1. Click on Cards, point to Financial and click on Checkbook to open the Checkbook Maintenance window.

2. In the Checkbook Maintenance window, click on the right scroll button in the bottom left corner of the window. Scroll through each checkbook to make sure the Bank Account number is not assigned to more than one checkbook, even if it is inactive.

Note: If you have numerous checkbooks, you may also review this information by looking at the CM Checkbook Master (CM00100) table using a SQL Query tool. To do this, follow these steps:

a. Start the Support Administrator Console, Microsoft SQL Query Analyzer, or SQL Server Management Studio. To do this, use one of the following methods depending on the program that you are using.

Method 1: For SQL Server Desktop Engine

If you are using SQL Server Desktop Engine (also known as MSDE 2000), start the Support Administrator Console. To do this, click Start, point to All Programs, point to Microsoft Administrator Console, and then click Support Administrator Console.

Method 2: For SQL Server 2000

If you are using SQL Server 2000, start SQL Query Analyzer. To do this, click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.

Method 3: For SQL Server 2005

If you are using SQL Server 2005, start SQL Server Management Studio. To do this, click Start, point to All Programs, point to Microsoft SQL Server 2005, and then click SQL Server Management Studio.

Method 4: For SQL Server 2008

If you are using SQL Server 2008, start SQL Server Management Studio. To do this, click Start, point to All Programs, point to Microsoft SQL Server 2008, and then click SQL Server Management Studio.
SQL Server Management Studio. In a query window, execute this script against the company database to review the BNKACTNM field for all the checkbooks at once:

b. Execute the following statement against the company database:

select * from CM00100 order by BNKACTNM desc

3. If you find the Bank Account number used on multiple checkbooks, remove the Bank Account from the inactive or incorrect checkbook in the Checkbook Maintenance window and Save


4. Test the Electronic Reconcile import again.



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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2504850
Revision : 1
Created on : 1/7/2017
Published on : 8/5/2011
Exists online : False
Views : 98