Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

MED-V 2.0 workspace setup fails with a fatal error


View products that this article applies to.

Symptoms

When installing the MED-V 2.0 workspace on a Windows 7 machine, a fatal error occurs and in the MED-V install log and the following error is reported:


0810 Decompressing VHD to: C:\ProgramData\Microsoft\Medv\Workspace\MEDV.vhd

0811 A generic exception occured while unpacking VHD

0812 System.IO.IOException: I/O error encountered in attempting to open file ---> Xceed.Compression.CompressionException: Expected end of stream not found

0813    at Xceed.Compression.ManagedDeflateDecompressor.Decompress(Byte buffer, Int32 offset, Int32 count, Boolean& endOfData, Byte& decompressed, Int32& remaining)

0814    at Xceed.Compression.CompressedStream.Read(Byte buffer, Int32 offset, Int32 count)

0815    at Xceed.Utils.Streams.ChecksumStream.Read(Byte buffer, Int32 offset, Int32 count)

0816    at Xceed.Zip.ReaderWriter.ZipReader.ReadItemData(Byte buffer, Int32 offset, Int32 count)

0817    at Microsoft.Medv.WorkspaceCustomActions.VhdUtil.Decompress(Session session, String compressedVhdPath, String vhdInstallationFilePath, Boolean overwriteExistingVhd)

0818    --- End of inner exception stack trace ---

0819    at Microsoft.Medv.WorkspaceCustomActions.VhdUtil.Decompress(Session session, String compressedVhdPath, String vhdInstallationFilePath, Boolean overwriteExistingVhd)

0820 at Microsoft.Medv.WorkspaceCustomActions.CustomActions.InstallVhd(Session session)0821 CustomAction InstallVhdFile returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

↑ Back to the top


Cause

This issue can be caused by antivirus software that is installed on the Windows 7 system if the real-time scanning component is configured to monitor the MED-V files.

↑ Back to the top


Resolution

  1. To resolve this issue, configure the real-time scanning component within your antivirus software to exclude the following files:
    • *.VHD - These represent the Virtual Hard Disk Image files. These will be on all MED-V version 2.0 clients (Windows 7 host machines) running Workspaces.

      *.VSV
       - These represent Virtual PC Saved State files. These will be on all MED-V clients running Workspaces.

      *.MEDV - This is the packed image format used by MED-V version 2.0. These will be present on the MED-V mage Distribution Servers, locally packed images on MED-V Administration workstations, and as pre-staged images (workspaces) on the clients. 

      *.VMC - These represent the Base Virtual Machine Settings File. Will be found on all MED-V v.2 Clients and test/packaging workstations.

      *.VUD - These represent Virtual PC Undo Disk Files. These may appear on testing/packaging workstations when test images are being used to finalize workspace policies.

↑ Back to the top


More Information

For information on adding exclusions or exceptions to a specific Anti-Virus software, please refer to the documentation provided by the vendor. For Microsoft Forefront, please review the following article: http://technet.microsoft.com/en-us/library/bb418942.aspx

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2504827
Revision : 2
Created on : 3/27/2020
Published on : 3/27/2020
Exists online : False
Views : 145