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FIX: "Object reference not set to an instance of an object" error message when you use Commerce Server adapters for BizTalk Server from Commerce Server 2007 to receive orders


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Microsoft BizTalk Server 2006 or that is running Microsoft BizTalk Server 2006 R2.
  • You install Commerce Server adapters for Microsoft BizTalk Server on the computer.

    Note Commerce Server adapters for BizTalk Server in a discussion are included in Commerce Server 2007.
  • You create and configure a receive location for an endpoint by using the Orders receive adapter to receive orders from Commerce Server 2007.
In this scenario, the receive location for the endpoint may stop responding intermittently. Additionally, an error message that resembles the following is logged in the Application log:
Event Type: Error
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5673

Description:
The Messaging Engine received an error from transport adapter "Commerce Server Orders" when notifying the adapter with the BatchComplete event. Reason "Object reference not set to an instance of an object.".


Note This issue typically occurs when there is network latency, or when the computer that is running the Orders Web service also has other processes running. For example, a large catalog import operation is being executed.

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Cause

This issue occurs because the batch of transactions is not committed to a message box in BizTalk Server when it tries to receive orders from Commerce Server 2007.

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Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Commerce Server adapters for Microsoft BizTalk Server installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. You must restart the BizTalk host instance after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft Commerce Server Adapters for Microsoft BizTalk Server
File nameFile versionFile sizeDateTimePlatform
Microsoft.commerceserver.adapter.orders.receiveadapter.dll6.0.4109.5652,07201-Feb-201110:37x86


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about�the architecture for BizTalk adapter, visit the following Microsoft Developer Network (MSDN) website:For more information about�how to configure�an Orders Adapter Endpoint, visit the following MSDN website:

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, KB2503997

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Article Info
Article ID : 2503997
Revision : 1
Created on : 3/1/2011
Published on : 3/1/2011
Exists online : False
Views : 459