Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Display driver stopped responding but has recovered" error in a Windows 7 SP1-based VM that has a RemoteFX video adapter


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a virtual machine (VM) that is running Windows 7 Service Pack 1 (SP1).
  • You add a RemoteFX video adapter to the VM.
  • You configure the RemoteFX video adapter for multiple monitors, and then you leave the VM session idle for a while. Or, you leave the VM session idle until the session locks, and then you enter credentials to unlock the VM session.
In this scenario, you may receive the following error message on the VM:
Display driver stopped responding and has recovered

↑ Back to the top


Cause

This issue occurs because the RemoteFX video adapter driver is reset.

When the session is idle, the power management configuration tries to turn off the display. Therefore, you receive the error message when the RemoteFX video adapter driver recovers.
To resolve this issue, disable the Turn off the Display (Plugged In) and Turn off the Display (On Battery) power settings by using one of the following methods:
  • Use the Group Policy settings
    To resolve this issue by using the Group Policy settings, follow these steps:
    1. Log on to the VM as a member of the Local Administrators group.
    2. Click Start, type gpedit.msc in the search box, and then press ENTER.
    3. In the Local Group Policy Editor, expand Administrative Templates under Computer Configuration, expand System, expand Power Management, and then click Video and Display Settings.
    4. In the dialog box that opens, double-click Turn off the Display (Plugged In), click Enabled, type 0 in the Turn Off the Display (seconds) box, and then click OK.
    5. In the dialog box that opens, double-click Turn off the Display (On Battery), click Enabled, type 0 in the Turn Off the Display (seconds) box, and then click OK.
    6. Restart the VM.
  • Use the powercfg command
    To resolve this issue by using the powercfg command, follow these steps:
    1. Log on to the VM as a member of the Local Administrators group. 
    2. Click Start, type command prompt in the search box, and then click Command Prompt in the list of results.
    3. At the command prompt, type the following commands:
      • powercfg -X -monitor-timeout-ac 0
      • powercfg -X -monitor-timeout-dc 0

↑ Back to the top


Keywords: kbprb, kbexpertiseinter, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2501816
Revision : 1
Created on : 1/7/2017
Published on : 2/16/2011
Exists online : False
Views : 319