Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: "502 Proxy Error. An unknown error occurred while processing the certificate. (-2146893017)" error when you try to access a website over HTTPS in Forefront TMG 2010 if HTTPS inspection is enabled


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You enable the HTTPS inspection feature in Microsoft Forefront Threat Management Gateway (TMG) 2010.
  • You try to use an HTTPS URL to access a website that requires a client certificate through Forefront TMG 2010.
  • You add the website to the Destination Exception list for HTTPS inspection.
In this scenario, you cannot access the website, and you receive the following error message:
502 Proxy Error. An unknown error occurred while processing the certificate. (-2146893017)

↑ Back to the top


Cause

This issue occurs because Forefront TMG 2010 sends an empty client certificate to the web server in the initial SSL handshake.

When a request that contains an empty client certificate is sent, some web servers accept and renegotiate the client certificate. However, other web servers may return an SSL error when the web server receives an empty client certificate, and Forefront TMG does not correctly handle the server error. Therefore, the error message that is mentioned in the "Symptoms" section is generated.

Note An example of a web server that accepts and renegotiates an empty client certificate is an IIS web server.

↑ Back to the top


Resolution

To resolve this issue, follow these steps:
  1. Install the software update that is described in the following Microsoft Knowledge Base (KB) article:
    2498770 Software Update 1 Rollup 3 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 1
  2. Run the script that is in the following article:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
982550 FIX: Error message occurs when you try to access a web server that requires a client certificate if HTTPS inspection is enabled in Forefront TMG 2010: "Error Code: 502 Proxy Error. The message received was unexpected or badly formatted. (-2146893018)"
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbfix, kbexpertiseinter, kbsurveynew, kbqfe, kb

↑ Back to the top

Article Info
Article ID : 2501777
Revision : 1
Created on : 3/21/2017
Published on : 2/25/2011
Exists online : False
Views : 259