Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: "A security package specific error occurred" error when you run a recurring report on a Forefront TMG 2010 server that is managed by an EMS and that is in a workgroup


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You add a Microsoft Forefront Threat Management Gateway (TMG) 2010 server to a workgroup.
  • You add a Forefront TMG 2010 Enterprise Management Server (EMS) to a domain.
  • You add the Forefront TMG 2010 server to an array that is managed by the Forefront TMG 2010 EMS.
  • You configure a recurring report, and then you run the report on the Forefront TMG 2010 server.
In this scenario, you receive the following error message.
A security package specific error occurred
Additionally, the report is not generated.

↑ Back to the top


Cause

This issue occurs because the TMG Job Scheduler (Isasched) service incorrectly tries to read its config file directly from the EMS.

When Isasched reads the config file, Isasched uses a remote procedure call (RPC) to decrypt secrets on the EMS. These secrets include the ReportJob.PublishCredentials property and other properties in the config file. However, there is no user to authenticate the RPC for Isasched. Therefore, the error message that is mentioned in the "Symptoms" section is generated.

↑ Back to the top


Resolution

Install the software update that is described in the following Microsoft Knowledge Base (KB) article:
2498770 Software Update 1 Rollup 3 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 1

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2501646
Revision : 1
Created on : 3/21/2017
Published on : 2/25/2011
Exists online : False
Views : 269