Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Desktop Experience fails installation with error 0x8000FFFF


View products that this article applies to.

Symptoms

When attempting to install the Desktop Experience component on Windows Server 2008, it may fail with the following error:

<Error>: Attempt to install Desktop Experience failed with error code 0x8000FFFF. Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))

↑ Back to the top


Cause

This issue can occur if the Desktop Experience component has previously been installed and uninstalled. Several Windows Updates which include Media Player components are installed if the Desktop Experience is installed, but they are not removed if it is later uninstalled. These updated components can cause the reinstallation of the Desktop Experience to fail due to being newer than expected. These updates are known to include:

974431 The October 2009 stability and reliability update for Windows 7 and Windows Server 2008 R2 is available.
http://support.microsoft.com/default.aspx?scid=kb;EN-US;974431

973540 MS09-037: Description of the security update for Windows Media Player: August 11, 2009
http://support.microsoft.com/default.aspx?scid=kb;EN-US;973540

968816 MS09-047: Description of the security update for Windows Media Format Runtime, Windows Media Services, and Media Foundation: September 8, 2009
http://support.microsoft.com/default.aspx?scid=kb;EN-US;968816

954155 MS09-051: Description of the security update for Windows Media Audio Voice Decoder: October 13, 2009
http://support.microsoft.com/default.aspx?scid=kb;EN-US;954155

↑ Back to the top


Resolution

Uninstall any of these updates that are installed on the system, reinstall the Desktop Experience component and then reinstall these updates.

↑ Back to the top


More Information

Microsoft has confirmed this to be a problem with the products listed above.

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2500700
Revision : 1
Created on : 1/7/2017
Published on : 1/24/2011
Exists online : False
Views : 500