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NAV exceptions are logged in the Dynamics Connector when running the Account to NAV Customer Card map


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Symptoms

When running the Account to NAV Customer Card map in the Dynamics NAV Adapter, the following error occurs:

[Account to NAV Customer Card] has encountered an error while processing key [551d5211-b925-e011-9c0e-00155d430600]. Exception occurred in Microsoft Dynamics NAV

1: If the Microsoft Dynamics CRM Contact contains another Contact as the Parent Customer, this scenario is not supported in Microsoft Dynamics NAV.

2: If an order is canceled in Microsoft Dynamics CRM, the associated sales order in Microsoft Dynamics NAV is not updated because there is no "canceled" status.

Additionally, the following error is logged if tracing is enabled on the Integration Service:

WARNING TID:TP-5 [2011-01-21T16:51:35.1340078-06:00]: [Account to NAV Customer Card] has encountered an error while processing key [2a6f8576-b025-e011-9c0e-00155d430600]. Exception occurred in Microsoft Dynamics NAV

                --- Exception Dump ---
                Caught Exception: Exception occurred in Microsoft Dynamics NAV
                Stack trace:
   at Microsoft.Dynamics.Integration.Adapters.Nav2009.NavObjectProvider.WriteObject(Object value)
   at Microsoft.Dynamics.Integration.AdapterAbstractionLayer.MixedObjectProviderProxy.WriteObject(Object value)
   at Microsoft.Dynamics.Integration.Service.RecordRetryThread.Run(Object task)
                Inner Exception: Sequence contains more than one matching element
                Stack trace:
   at System.Linq.Enumerable.SingleOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
   at Microsoft.Dynamics.Integration.Adapters.Nav2009.CustomerObjectProvider.WriteDynamicObject(Object value)
   at Microsoft.Dynamics.Integration.Adapters.Nav2009.NavObjectProvider.WriteObject(Object value)

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Cause

This error occurs when the account being integrated from CRM to NAV has an additional address that exactly matches the primary address.

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Resolution

This issue will be resolved in a future update to the Dynamics NAV Adapter.

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More Information

Despite this message, the Account is successfully integrated from CRM into NAV.

How to: Set Up and Enable the Connector for Microsoft Dynamics
http://msdn.microsoft.com/en-us/library/gg502494.aspx

Walkthrough: Setting up Microsoft Dynamics NAV and Microsoft Dynamics CRM to Use Connector
http://msdn.microsoft.com/en-us/library/gg481835.aspx

Mapping Entities Between Microsoft Dynamics NAV and Microsoft Dynamics CRM
http://msdn.microsoft.com/en-us/library/gg502482.aspx

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2500573
Revision : 1
Created on : 1/7/2017
Published on : 1/28/2011
Exists online : False
Views : 328