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You encounter timeout error when using Deployment Web Service.


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Symptoms

You encounter a timeout error when using the Deployment Web Service of Microsoft Dynamics CRM 2011 by using Microsoft.Xrm.Sdk.Deployment.dll


Error Message
System.TimeoutException: The request channel timed out while waiting for a reply after 00:01:59.9531229. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.

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Cause

The proxy which is created by ProxyClientHelper.CreateClient method has default timeout of 2 minutes.

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Resolution

Instead of using ProxyClientHelper.CreateClient method, reference Deployment Web Service and create proxy DeploymentServiceClient service = new DeploymentServiceClient("CustomBinding_IDeploymentService");

After creating the proxy, set timeout value for SendTimeout to have enough timeout value for your operation.

Example:
// Set SendTimeout as 4 minutes.
service.Endpoint.Binding.SendTimeout = new TimeSpan(0, 4, 0);
           

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More Information

Since PowerShell uses the same dll to create proxy, there is no workaround for the timeout at this time when using Powershell.

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2500491
Revision : 1
Created on : 1/7/2017
Published on : 1/25/2011
Exists online : False
Views : 242