Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A SCSI device does not burn DVD discs when you use IMAPIv2.0 for Windows XP and for Windows Embedded Standard 2009


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows XP or Windows Embedded Standard 2009.
  • You try to use Image Mastering API v2.0 (IMAPIv2.0) for Windows XP to burn DVD discs on a SCSI-based CD/DVD writer.
  • The SCSI-based CD/DVD writer has no serial number.
In this scenario, IMAPI does not initialize the SCSI-based CD/DVD writer, and the SCSI-based CD/DVD writer does not burn the DVD discs.

↑ Back to the top


Cause

This issue occurs because of an additional check in the SCSI port driver.

When the SCSI device does not have a serial number, the length of the serial number is assumed to be zero. However, a check returns a different result for the required memory length. IMAPI2 checks this result and then cannot initialize the writer. Therefore, the CD/DVD burning process fails.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Embedded Standard 2009.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Embedded Standard 2009 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Embedded Standard 2009
File nameFile versionFile sizeDateTime
Scsiport.sys5.1.2600.607396,38427-Jan-201113:56

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbautohotfix, kb

↑ Back to the top

Article Info
Article ID : 2498072
Revision : 1
Created on : 1/7/2017
Published on : 4/13/2011
Exists online : False
Views : 269