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The Remote Desktop Gateway service crashes under a heavy workload in Windows Server 2008 R2


View products that this article applies to.

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Symptoms

Consider the following scenario:
  • You install the Remote Desktop Gateway (RD Gateway) role service on a computer that is running Windows Server 2008 R2.
  • You configure Remote Desktop resource authorization policies (RD RAP) on the computer.
  • Multiple users connect to the computer at the same time.
  • The computer is under a heavy workload.
In this scenario, the Remote Desktop Gateway service crashes, and all remote desktop services connections through the computer are lost. Additionally, the following events are added to the System log, and the Microsoft-Windows-TerminalServices-Gateway/Admin log.

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Cause

This issue occurs because of a race condition in the RD Gateway service. When the race condition occurs, the RD Gateway service incorrectly accesses invalid memory and then crashes.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows Server 2008 R2RTMGDR
    6.1.760
    0.20xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.17xxx
    Windows Server 2008 R2SP1GDR
    6.1.760
    1.21xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Aaedge.dll6.1.7600.20904303,61618-Feb-201106:43x64
Aaedge.mofNot applicable1,26810-Jun-200920:31Not applicable
Aatspp.dll6.1.7600.1638565,02414-Jul-200901:39x64
Aatspp.mofNot applicable1,27110-Jun-200920:31Not applicable
Rap.xmlNot applicable89510-Jun-200920:31Not applicable
Tsgateway.xmlNot applicable42910-Jun-200920:31Not applicable
Tsgclean.exe6.1.7600.16385428,03214-Jul-200901:39x64
Tsproxy-edgeadapter-ppdlic.xrm-msNot applicable3,01818-Feb-201106:55Not applicable
Aaedge.dll6.1.7601.21663306,17618-Feb-201106:06x64
Aaedge.mofNot applicable1,26805-Nov-201001:52Not applicable
Aatspp.dll6.1.7601.1751465,02420-Nov-201013:25x64
Aatspp.mofNot applicable1,27105-Nov-201001:52Not applicable
Rap.xmlNot applicable89505-Nov-201001:52Not applicable
Tsgateway.xmlNot applicable42905-Nov-201001:52Not applicable
Tsgclean.exe6.1.7601.17514428,03220-Nov-201013:25x64
Tsproxy-edgeadapter-ppdlic.xrm-msNot applicable3,01818-Feb-201106:22Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_4f3aadb4e3e8b363c70622bc744fbd37_31bf3856ad364e35_6.1.7600.20904_none_ae29d0c258368f98.manifest
File versionNot applicable
File size711
Date (UTC)18-Feb-2011
Time (UTC)14:06
PlatformNot applicable
File nameAmd64_88741f3fb654c182affbd7a59900dcd4_31bf3856ad364e35_6.1.7601.21663_none_6cf497181843a269.manifest
File versionNot applicable
File size711
Date (UTC)18-Feb-2011
Time (UTC)14:06
PlatformNot applicable
File nameAmd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.20904_none_9ade8a6fff43eee7.manifest
File versionNot applicable
File size99,560
Date (UTC)18-Feb-2011
Time (UTC)14:07
PlatformNot applicable
File nameAmd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7601.21663_none_9c8305bdfc9bebfb.manifest
File versionNot applicable
File size99,560
Date (UTC)18-Feb-2011
Time (UTC)14:07
PlatformNot applicable

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Keywords: kb, kbmdd, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2497787
Revision : 3
Created on : 9/20/2018
Published on : 9/21/2018
Exists online : False
Views : 329