Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when a user tries to go offline in the Microsoft Dynamics CRM Client for Outlook: "An error occurred during deleting database"


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

↑ Back to the top


Symptoms

Consider the following scenario:
  • A client computer is used by more than one user or is used in a Terminal Server or Citrix environment.
  • A user goes offline. Then, a second user clicks Go Offline.

In this scenario, the second user cannot go offline. In fact, no other users can go offline. Additionally, you receive the following error message:

An error occurred during deleting database. Contact your Microsoft Dynamics CRM administrator for assistance and try going offline again.

↑ Back to the top


Cause

Only one user can be configured to go offline in the Microsoft Dynamics CRM Client for Microsoft Office Outlook.

↑ Back to the top


Resolution

This behavior is by design. In Microsoft Dynamics CRM 2011, you can install and then configure the Microsoft Dynamics CRM Client for Outlook. Then, you can install the offline components by clicking the Go Offline button.

If you do not want users to be able to click the Go Offline button, you can use one of the following options.

Option 1


Remove the Go Offline permissions for the users whom you do not want to be able to see the Go Offline button. To do this, follow these steps:
  1. For a user who has permissions to change a CRM Security Role, click Settings, click Administration, and then click Security Roles.
  2. Click to open the Security Role that you have to change. (For example, click Sales Manager)
  3. Click the Business Management tab, and then click to clear the Go Offline check box in the Miscellaneous Privileges section.
  4. Click Save, and then click Close.

    Note It may take 5 minutes or more before the button disappears on the client toolbar if the client is already configured.

Option 2


Disable the Go Offline button for all users on each computer, and then install the Microsoft Dynamics CRM Client for Outlook together by using the disableofflinecapability switch. To do this, follow these steps:
  1. Click Start, click Run, and then type the path of the Setupclient.exe file.
  2. se the /disableofflinecapability switch to install the Microsoft Dynamics CRM Client for Outlook. (For example, use the C:\Client\i386\SetupClient.exe /disableofflinecapability command.)
  3. Click Install Now or use the /q switch to do a quiet installation without user prompts.

Option 3


Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

If you have already installed the Microsoft Dynamics CRM Client for Outlook, you can change the LightClient registry keys so that any new users who run the configuration do not see the Go Offline button. To do this, follow these steps:
  1. Click Start, click Run, type Regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
  3. Right-click the LightClient registry key, and then click Modify.
  4. Change the Value to 1, select Decimal, and then click OK.
  5. Start the Microsoft Dynamics CRM Client for Outlook.

    Note It may take 5 minutes or more before the button disappears on the client toolbar if the client is already configured.
  6. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRMClient

    Note If you are using a 64-bit client computer and have a 3- bit version of Microsoft Office installed, the appropriate registry subkey is as follows:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\MSCRMClient
  7. Right-click the LightClient registry key, and then click Modify.
  8. Change the Value to 1, select Decimal, and then click OK. When a new configuration is run, the Go Offline button will be removed.

Note When you change the registry entry in HKEY_CURRENT_USER, the change will affect only the user who is currently logged in. To apply the change to multiple users, locate their record under HKEY_Users\. Or, apply the key by using a Group Policy to multiple/other users.

↑ Back to the top


More Information

If a user has already gone offline and a different user must be able to go offline on the same computer, you have to drop the database from the previous user. For more information about how to drop a SQL Express database, visit the following Microsoft Developer Network (MSDN) website:

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2496443
Revision : 1
Created on : 1/7/2017
Published on : 6/8/2012
Exists online : False
Views : 265