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"0x00000027" Stop error occurs when you access shared network resources by using the SMB 2.0 protocol in Windows Server 2008 R2 or in Windows 7


View products that this article applies to.

Symptoms

When you access shared network resources by using the Server Message Block (SMB) 2.0 protocol on a computer that is running Windows Server 2008 R2 or Windows 7, you receive the following Stop error message:
STOP: 0x00000027 (parameter1, parameter2, parameter3, parameter4) The RDR_FILE_SYSTEM

Notes
  • The parameters in this error message vary, depending on the configuration of the computer.
  • Not all "0x00000027" Stop errors are caused by this issue.

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Cause

This issue occurs because the SMB redirector (Mrxsmb20.sys) incorrectly handles the file name information for a shared file or a shared directory if the shared file or the shared directory was renamed or deleted.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described that is in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2.

Registry information

You do not have to make any changes to the registry to use this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine to which operating system each hotfix applies.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.1.760 0 . 20xxxWindows 7 and Windows Server 2008 R2RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb20.sys6.1.7600.2088496,76820-Jan-201104:56x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb20.sys6.1.7600.20884128,00020-Jan-201105:20x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb20.sys6.1.7600.20884311,80820-Jan-201104:43IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameX86_3b43965b8c6f9a47373f91660d7a9fa9_31bf3856ad364e35_6.1.7600.20884_none_1bcdf04ef88905df.manifest
File versionNot applicable
File size701
Date (UTC)20-Jan-2011
Time (UTC)17:17
PlatformNot applicable
File nameX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.20884_none_8b39efd80437f176.manifest
File versionNot applicable
File size4,035
Date (UTC)20-Jan-2011
Time (UTC)07:37
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_3a8569ccd50f0b28b740226e06bf7ef7_31bf3856ad364e35_6.1.7600.20884_none_8168abfda349ed15.manifest
File versionNot applicable
File size705
Date (UTC)20-Jan-2011
Time (UTC)17:17
PlatformNot applicable
File nameAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.20884_none_e7588b5bbc9562ac.manifest
File versionNot applicable
File size4,039
Date (UTC)20-Jan-2011
Time (UTC)08:38
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_0291ca2ae41cbcca4b99db63f4880060_31bf3856ad364e35_6.1.7600.20884_none_20eac8ace744cc61.manifest
File versionNot applicable
File size703
Date (UTC)20-Jan-2011
Time (UTC)17:17
PlatformNot applicable
File nameIa64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.20884_none_8b3b93ce0435fa72.manifest
File versionNot applicable
File size4,037
Date (UTC)20-Jan-2011
Time (UTC)08:35
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbHotfixServer, kbfix, kbexpertiseadvanced, kbsurveynew, KB2494418

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Article Info
Article ID : 2494418
Revision : 2
Created on : 2/10/2011
Published on : 2/10/2011
Exists online : False
Views : 336