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Msinfo32.exe takes a long time to display or export system information on a computer that has many MSI-X-supported devices and that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2. The computer has many processor cores and many MSI-X-supported devices. For example, the computer has 64 processor cores and 16 Gigabit Ethernet controllers that support MSI-X and that use many interrupts.
  • You run the Msinfo32.exe utility.
  • In the System Information navigation pane, you expand Hardware Resources, and then you click IRQs. Or, you try to export the system information to a text file.
In this scenario, it takes Msinfo32.exe a long time to display the device information or to export the system information.

Note Other applications may also experience this issue when they call the Win32_IRQResource WMI class to query IRQ resource information.

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Cause

The issue occurs because the Win32_IRQResource WMI class does not cache results. Instead, it enumerates all device IRQs during each request. Therefore, the time it takes to enumerate all IRQ resources grows exponentially when the number of IRQ resources increases.

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Resolution

After you apply this hotfix, the Win32_IRQResource WMI class implements a caching mechanism when it retrieves IRQ information from the system. When a Win32_IRQResource instance is first created, it reads the IRQ information for all IRQ assignments on the system and then stores the information in a cache. During later calls to Win32_IRQResource, the cache is used to fulfill the query.

Specifically, the cache is refreshed if one of the following conditions is true (whichever condition comes first):
  • A query has not been processed in more than two seconds.
  • Ten seconds have passed since the cache was last refreshed.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    20xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.
    21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.1.7600.209081,340,92824-Feb-201105:43x86
Cimwin32.dll6.1.7601.216671,342,97624-Feb-201105:12x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.1.7600.209082,055,16824-Feb-201106:21x64
Cimwin32.dll6.1.7601.216672,058,75224-Feb-201106:18x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.1.7600.209084,280,32024-Feb-201105:19IA-64
Cimwin32.dll6.1.7601.216674,280,32024-Feb-201105:00IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2018710 On a system with many MSI-X supported devices, MSINFO32 can take an extended amount of time to export the system data to a file

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size2,661
Date (UTC)24-Feb-2011
Time (UTC)14:50
PlatformNot Applicable
File nameX86_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7600.20908_none_d0646ddb803d5f00.manifest
File versionNot Applicable
File size5,224
Date (UTC)24-Feb-2011
Time (UTC)06:19
PlatformNot Applicable
File nameX86_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7601.21667_none_d208e9297d955c14.manifest
File versionNot Applicable
File size5,224
Date (UTC)24-Feb-2011
Time (UTC)05:44
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7600.20908_none_2c83095f389ad036.manifest
File versionNot Applicable
File size5,228
Date (UTC)24-Feb-2011
Time (UTC)07:07
PlatformNot Applicable
File nameAmd64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7601.21667_none_2e2784ad35f2cd4a.manifest
File versionNot Applicable
File size5,228
Date (UTC)24-Feb-2011
Time (UTC)06:57
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,103
Date (UTC)24-Feb-2011
Time (UTC)14:50
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7600.20908_none_d06611d1803b67fc.manifest
File versionNot Applicable
File size5,226
Date (UTC)24-Feb-2011
Time (UTC)07:10
PlatformNot Applicable
File nameIa64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7601.21667_none_d20a8d1f7d936510.manifest
File versionNot Applicable
File size5,226
Date (UTC)24-Feb-2011
Time (UTC)06:33
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,168
Date (UTC)24-Feb-2011
Time (UTC)14:49
PlatformNot Applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2492536
Revision : 3
Created on : 9/20/2018
Published on : 9/21/2018
Exists online : False
Views : 319