Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XCON: MTA Stops Processing While Handling Incoming Mail


View products that this article applies to.

Symptoms

Although the EMSMTA process is still apparently running, no work is being done, and no events are logged. If you stop and restart the message transfer agent (MTA), you may receive the following error message:
Windows NT Error 1067

↑ Back to the top


Cause

The MTA has received a message from a foreign MTA that contains a trace record with a zero-length Arrival Time attribute. Processing this illegally-formed attribute causes internal context information to be overwritten.

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Exchange Server 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014 XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack

↑ Back to the top


Workaround

There is no workaround for this issue. If you create a new MTA database (MTAWIPE), it allows the MTA to start again, but the foreign MTA resends the offending message.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Exchange Server 5.5 Service Pack 4.

↑ Back to the top


More information

With the application of the hotfix, the MTA rejects the invalid message, logs an event, and sends a non-delivery report (NDR) back with a diagnostic of Invalid Argument.

↑ Back to the top


Properties

↑ Back to the top


Article Info
Article ID : 248732
Revision : 4
Created on : 1/1/0001
Published on : 1/1/0001
Exists online : False
Views : 430