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FIX: Temporary CAL is dispensed when you connect to an RDP server on a Windows Embedded POSReady device or Windows Thin PC


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In a network environment, there is a licensing server that provides remote desktop access to client computers.
  • You have a client computer that is running one of the following operating systems:
    • Windows Embedded POSReady 2009
    • Windows Thin PC
    • Windows Embedded POSReady 7
  • The client computer does not have a USB device attached. For example, the computer uses a PS/2 mouse and keyboard.
  • You connect to the licensing server by using Remote Desktop Protocol (RDP) on the client computer.
  • You shut down the client computer, and then you restart it.
  • You connect to the licensing server again by using RDP.
In this scenario, an additional temporary client access license (CAL) is dispensed unexpectedly. Additionally, event ID 23 is logged in the event log. 

Note The event log states that the registry filter cannot start because it cannot access the RAM disk file that is the backing store for the Terminal Services client access license (TS CAL) registry key.

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Cause

This issue occurs when timing issues prevent the registry filter from starting.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


Download information

To download the update, go to the following Microsoft Download Center website: 

Prerequisites

To apply this hotfix, you must be running Windows Embedded POSReady 2009, Windows Thin PC, or Windows Embedded POSReady 7.

Restart requirement

You do not have to restart the computer after you install the hotfix.
File information
The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Regfinit.dll5.1.2600.551219,81615-Aug-201102:44x86
Regflt.sys2.0.2600.819230,05615-Aug-201102:44x86
Regfltuser.exe5.1.2600.551212,64815-Aug-201102:44x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbhotfixserver, kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced, atdownload, kb

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Article Info
Article ID : 2487305
Revision : 1
Created on : 1/7/2017
Published on : 4/19/2013
Exists online : False
Views : 196