Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XFOR: Cannot Reply All to SMTP Reply Received from Notes R5 User


View products that this article applies to.

This article was previously published under Q248664

↑ Back to the top


Symptoms

If you compose a message that includes a Simple Mail Transfer Protocol (SMTP) one-off address and display name on the Cc line, and then send the message to a Lotus Notes recipient, the Notes recipient may reply all to the message. When you view the reply in an e-mail client, the SMTP address may appear in the following format:
"User1@Host1@SMTP@Domain1" <User1@Host1>@SMTP@Domain1
Note that multiple SMTP addresses are appended, which is not the correct format. As a result, if you attempt to reply all to the original reply, the new reply cannot be delivered to the SMTP recipient. This issue is known to occur when the messages are sent between an Exchange Server computer and a Notes Release 5 (R5) server through the Exchange Notes Connector, and the Notes recipient uses a Notes R5 client to reply all to the original message.

In addition, if you compose a new message that includes an implicitly encapsulated SMTP address and display name on the Cc line, and then send the message from a Notes R5 client to an Exchange Server recipient, the address may not be formatted correctly when the Exchange Server recipient views the message in an e-mail client. However, if the Exchange Server recipient replies all to the message, the reply is successfully delivered to the SMTP recipient.

↑ Back to the top


Cause

This issue occurs when the Exchange Notes Connector incorrectly parses an SMTP address that includes a display name enclosed in quotes and containing one or more at signs (@).

In addition, when an Exchange Server user replies all to a message that contains an address in this format, a complete address is used as a display name, causing Notes to construct an invalid Internet address in the following format:
""User1@Host1@SMTP@Domain1" <User1@Host1>@SMTP@Domain1" <User1@Host1>@SMTP@Domain1

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Exchange Server 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014� XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 4.

↑ Back to the top


More information

In an implicitly encapsulated SMTP address, the user and domain names are enclosed in angle brackets (<>), but "@SMTP" is not included in the address.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

↑ Back to the top


Keywords: KB248664, kbfix, kbexchange550sp4fix, kbexchange550presp4fix, kbbug

↑ Back to the top

Article Info
Article ID : 248664
Revision : 7
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 270