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XADM: Service Pack Upgrade Does Not Work with "Access Is Denied" Error Message and Event ID 7028


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This article was previously published under Q248445
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry

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Symptoms

When you perform an upgrade to an Exchange Server 5.5 service pack, the following error message may be displayed:
Processing file [SP install path]\sp2\eng\server\setup\i386\shared.ins at or near line 48
Access is denied
NT ID: 0xC0020005
The following event ID may be logged in the System log:
Event ID: 7028
Source: Service control manager
Description:
The winreg registry key denied access to system account programs. The Service Control Manager took ownership of the registry key.

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Cause

This issue can occur if the account that you use to log on to Microsoft Windows NT Server does not have sufficient permissions to modify the Winreg registry key.

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Resolution

To resolve this issue, you need to edit the registry:

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  1. Start Registry Editor (Regedt32.exe).
  2. Locate and select the following key in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\SecurePipeServers\Winreg
  3. On the Security menu, click Permissions.
  4. Add the Local Administrators group with Full Control permissions to the registry key Permissions page.
  5. Quit Registry Editor.

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More information

For additional information about event ID 7028, click the article number below to view the article in the Microsoft Knowledge Base:
234918� XADM: No Access to Diagnostics Logging Tab on Server Properties

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Keywords: KB248445, kbprb

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Article Info
Article ID : 248445
Revision : 5
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 564