Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

PostScript Printers Print "Insufficient Memory" Error Message


Symptoms

When you try to print a document on a PostScript printer, only a portion of the document may be printed. Also, the printer may print a page that indicates that the printer is out of memory. For example, the printer may print a page with the following text:
This job requires more memory than is available in this printer. Try on or more of the following and then print again:
For the output format choose Optimize for portability.
Reduce the number of fonts in this document.
Print the document in parts.

↑ Back to the top


Cause

This issue may occur if the printer does not have enough memory to complete the PostScript print job. For example, if your document contains TrueType fonts that are downloaded as Type42 (outline) fonts, your printer may not have enough memory to perform the Type42 font download in native TrueType format. When the printer tries to allocate space for the font download, the printer overruns its memory.

↑ Back to the top


Resolution

To resolve this issue, add more physical memory to the printer. For information about how to do so, view the documentation that was included with your printer.

↑ Back to the top


Workaround

To work around this issue, reduce the complexity of your PostScript print job. For example, set the TrueType Font Download option to Automatic, Outline, or Bitmap as follows:

  1. In Control Panel, open the Printers (or Printers and Faxes) folder.
  2. Right-click your PostScript printer, and then click Properties.
  3. Click Printing Preferences, click Layout, and then click Advanced.
  4. Double-click PostScript Options, and then click TrueType Font Download Option.
  5. In the True Type Font Download Option box, click Automatic. If Automatic is already selected, click Outline or Bitmap.
  6. Close the Printer Properties dialog box, and then close Control Panel.

↑ Back to the top


More Information

Microsoft has confirmed that this issue can occur when you use the PostScript printer driver that is included with Windows to print a PostScript job to any of the following printers:
  • Brother HL-1060 BR-Script2
  • Brother HL-1070 BR-Script2
  • Brother HL-2060 BR-Script2
  • (Brother HL-660 series)
  • Brother HL-1260 BR-Script2
  • Brother HL-1260e BR-Script2
  • Brother HL-1660 BR-Script2
  • Brother HL-1660e BR-Script2
  • Digital DEClaser 5100
  • Dataproducts Typhoon 20
  • Dataproducts Typhoon 8
  • Dataproducts Typhoon 8PM
  • Kyocera FS-1200 (KPDL-2)
  • Kyocera FS-1600 (KPDL-2)
  • Kyocera FS-1600+ (KPDL-2)
  • Kyocera FS-1700 (KPDL-2)
  • Kyocera FS-1700+ (KPDL-2)
  • Kyocera FS-3600 (KPDL-2)
  • Kyocera FS-3600+ (KPDL-2)
  • Kyocera FS-3700 (KPDL-2)
  • Kyocera FS-3700+ (KPDL-2)
  • Kyocera FS-6300 (KPDL-2)
  • Kyocera FS-6700 (KPDL-2)
  • Kyocera FS-7000 (KPDL-2)
  • Kyocera FS-1600A (KPDL-2)
  • Kyocera FS-3600A (KPDL-2)
  • HP DeskJet 1600CM
  • HP LaserJet 6P/6MP
  • Lexmark Optra LaserPrinter
  • Lexmark Optra Ep LaserPrinter
  • Lexmark Optra K 1220 Laser Printer
  • Lexmark Optra Plus LaserPrinter
  • Okidata OL610e/PS PostScript
  • Tektronix Phaser 300i v2013.113
  • Tektronix Phaser 300J v2013.113

↑ Back to the top


Keywords: kb, kbbillprodsweep, kbprint, kbprb, kbhardware, kberrmsg

↑ Back to the top

Article Info
Article ID : 248397
Revision : 5
Created on : 8/19/2020
Published on : 8/20/2020
Exists online : False
Views : 123