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FIX: It takes more than a minute to check out a file on a server that is running Visual Studio Team System 2008 Team Foundation Server Service Pack 1


Symptoms

When you check out a file from a server that is running Microsoft Visual Studio Team System 2008 Team Foundation Server Service Pack 1, it takes more than a minute to complete the checkout.

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Cause

This problem occurs because the Prc_ichecklockstatsus stored procedure runs very slowly in the Team Foundation Server data tier.

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Resolution

Important If you are running Team Explorer, Team Build or the TFS Proxy on the same computer as the TFS Application Tier, you will also need to install the hotfix that is described in the following Knowledge Base article:
974596 The size of the TfsVersionControl database is not reduced as much as expected when you run the "tf destroy" command in Microsoft Visual Studio 2008 Team Foundation Server

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

To download this hotfix from the MSDN Code Gallery, visit the following Microsoft website:
Note The MSDN Code Gallery displays the languages for which the hotfix is available. If you do not see your language listed, it is because the Code Gallery resource page is not available for that language.

Alternatively, you can download this hotfix from the following Microsoft Connect website:

Prerequisites

To apply this hotfix, you must have Visual Studio Team System 2008 Team Foundation Server Service Pack 1 installed.

Restart information

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
File nameFile versionFile sizeDateTimePlatform
Microsoft.teamfoundation.client.dll9.0.30729.5086458,75212-Jan-201118:00x86
Microsoft.teamfoundation.common.dll9.0.30729.5086331,77612-Jan-201118:00x86
Microsoft.teamfoundation.databaseinstaller.dll9.0.30729.50864,399,10412-Jan-201118:00x86
Microsoft.teamfoundation.dll9.0.30729.50861,060,86412-Jan-201118:00x86
Microsoft.teamfoundation.server.admin.dll9.0.30729.5086163,84012-Jan-201118:00x86
Microsoft.teamfoundation.versioncontrol.client.dll9.0.30729.5086516,09612-Jan-201118:00x86
Microsoft.teamfoundation.versioncontrol.common.dll9.0.30729.5086249,85612-Jan-201118:00x86
Microsoft.teamfoundation.versioncontrol.common.integration.dll9.0.30729.508632,76812-Jan-201118:00x86
Microsoft.visualstudio.teamsystem.integration.dll9.0.30729.5086208,89612-Jan-201118:00x86
Tfsadminutil.exe9.0.30729.508667,41612-Jan-201118:00x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbnotautohotfix, kbexpertiseinter, kbprb, kbsurveynew, kbfix, kbbug, kbqfe, kbhotfixserver, kb

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Article Info
Article ID : 2479245
Revision : 1
Created on : 1/7/2017
Published on : 3/2/2011
Exists online : False
Views : 85