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"Unable to connect to the Business Portal" when you try to connect the Outlook Vacation Request Add-In tool in Outlook to HRM Self Service Suite using Business Portal with Microsoft Dynamics GP


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Symptoms

You receive the following error message occurs when you set up the Vacation Request Options in Outlook 2003 or Outlook 2007 on all workstations, including the server:

Unable to connect to the Business Portal. You are not authorized to connect because of a protocol error, which may be related to the directory security settings for the Business Portal's virtual directory. These settings should allow Ingegrated Windows Authentication. Contact your Business Portal Administrator.

This error occurs when you try to connect the Outlook Vacation Request Add-In tool in Outlook to HRM Self Service Suite using Business Portal with Microsoft Dynamics GP.

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Cause

Check the settings for authentication access. Commonly Basic Authentication on the Microsoft Internet Information Services (IIS) Manager is enabled and should be disabled.

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Resolution

Method 1: Settings in IIS Manager

1. Grant permissions to the Domain Users group for your BP Web Site through Microsoft Internet Information Services (IIS) by following these steps:

a. Log onto the Business Portal (BP) Web Server running IIS. b. In the Control Panel, open Administrative Tools, and then click IIS Manager.
c. In the IIS Manager window, expand Web Sites.
d. Right-click your BP Web Site, and then click Permissions.
e. In the Security window, you should have a "Users" group similiar to (XXXXX\Users)Note XXXXX is a placeholder for the domain name)If this group does not exist, add the domain group.

2. Grant Integrated Windows Authentication for your BP Web Site through IIS by following these steps:
a. Log onto the BP Web Server running IIS.

b. In the Control Panel, open Administrative Tools, and then click IIS Manager
c. In the IIS Manager window, expand Web Sites.
d. Right-click your BP Web Site, and then click Properties.
e. Click the Directory Security tab.
f. In the Authentication and access control area, click Edit.
g. In the Authenticated access area, click to mark the Integrated Windows authentication check box.
h. In the Authenticated access area, make sure the Basic authentication check box is unmarked.
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To check Basic Authentication for IIS 7.0, use these steps:

a. On the workstation where Business Portal (BP) is installed, navigate to IIS Manager. To do this, click Start, click Control Panel, click Administrative Tools, and then double-click Internet Information Services (IIS) Manager.

b. In the Connections section in the left-margin, click to expand the appropriate connection site.

c. Click to expand Sites.

d. Right-click Business Portal (which may be under the Sharepoint site), and then click Switch to Features View.

e. In the Features View, you will see sections labeled ASP.NET and IIS. In the IIS section, double-click Authentication.

f. Click to select Basic Authentication.

g. In the right-hand margin under Actions, click Disable. (Note: If only 'Enable' is listed, then it already is disabled.)

h. Close the windows.


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3. Reset IIS. To do this, click Start, click Run, type IISRESET in the Open field, and then click OK to process.



4. Test again. If you still have the same problem, have a different user attempt to access the Vacation Request Options window from their Outlook Profile and see if they are able to access.

NOTE: Make sure Microsoft Outlook is installed as the MAPI compliant email system.

If this method does not work, then proceed to Method 2.



Method 2: Settings in Internet Explorer

1. In Internet Explorer, click Tools, click Internet Options, and then click to select the Advanced Tab. Under the Security section, make sure the Enable Integrated Windows Authentication is marked.

2. Add the BP URL to the Trusted Sites.



Method 3: Verify/test that you can browse to the URL shown in the Vacation Request Options in Outlook

1. After the Add-In is installed, open Outlook. Click Tools, click Vacation Request Options, and then click the Connection tab. Note the URL listed at the bottom of the window. This is the path that you will need to browse to using these steps. The following is an example of the URL:

http://localhost/BusinessPortal/Applications/HRM/VacationRequestWebService.asmx
(Note If you typed a Host Name, then it will replace the 'localhost' in this URL.)


2. Go to the server where BP is installed. Click Start, click Administrative Tools, and then click Internet Information Services (IIS) Manager.

3. Click to expand the database connection in the left margin.

4. Click to expand Sites, click to expand Business Portal, click to expand Business Portal again, click Applications, and then click the HRM folder. (Basically browse out to the same URL as you see in the Vacation Request Options window. Your steps/location to browse to may be different than what is listed in this example.)

5. Click Content View at the bottom of the window to view the files in the HRM folder.

6. Scroll down to find VacationRequestWebService.asmx. Right-click it, and then click browse. A VacationRequestWebService window should open up. It is important that it opens the web service window here. 

7. If the web service window opens, note the URL at the top of the page. The URL listed in the Vacation Request Options window should match this URL exactly.


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Article Info
Article ID : 2479170
Revision : 1
Created on : 1/7/2017
Published on : 9/6/2013
Exists online : False
Views : 210