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Two special characters are added at the end of the value when you copy a cell value from an Excel worksheet to Microsoft Dynamics NAV 5.0 Service Pack 1


View products that this article applies to.

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

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Symptoms

When you copy a cell value from an Excel worksheet to Microsoft Dynamics NAV 5.0 Service Pack 1 (SP1), two special characters are added at the end of the value. These special characters are rectangle signs as line feed characters.

Note If you run Microsoft Dynamics NAV and Microsoft Excel on a Windows 7-based computer, these two characters are not visible. If you run Microsoft Dynamics NAV and Microsoft Excel on a Windows Server 2003-based computer, the characters are visible.

These characters are added to the fields in Microsoft Dynamics NAV. Therefore, you must delete the special characters manually.

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Cause

This problem occurs because the carriage return (CR) character (ASCII 13) or the line feed (LF) character (ASCII 10) is added when a cell value is copied from an Excel worksheet to an application. The RoleTailored client (RTC) uses the text control, based on the standard .NET text control. If the .NET text control has the Multiline property set to "No," when you paste a control text that contains the CR character or the LF character, only the text before the characters is copied. If the text control has the Multiline property set to "True," the "new line" character can be used. For more information, visit the following Microsoft website:
TextBoxBase.Multiline Property
In a classic client, Microsoft Dynamics NAV must implement special processing for the Paste method of text edit controls. The "new line" characters must be removed from the end of line.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website: You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

PartnersCustomersIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.


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How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix, a hyperlink will be sent to you in an e-mail.


The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.


If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.


If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. Then, you must provide the password provided in the e-mail.


If you click Cancel, the download process stops.



How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files. To do this, follow these steps.

Step 1: Replace the Microsoft Dynamics NAV Client installation file

In the Microsoft Dynamics NAV Client installation, replace the following files by using the hotfix or the update file.
File nameFile versionFile sizeDateTimePlatform
Dbm.dll5.0.32009.0434,17609-Dec-201019:53x86
Fin.exe5.0.32009.010,747,90409-Dec-201019:31x86
Finhlink.exe5.0.32009.0339,96809-Dec-201019:44x86
Finsql.exe5.0.32009.010,809,34409-Dec-201020:17x86
Nc_netb.dll5.0.32009.0102,40009-Dec-201019:54x86
Nc_tcp.dll5.0.32009.0102,40009-Dec-201019:54x86
Nc_tcps.dll5.0.32009.0147,45609-Dec-201019:55x86
Ndbcs.dll5.0.32009.01,286,14409-Dec-201020:20x86
Slave.exe5.0.32009.0151,55209-Dec-201019:44x86
To replace the existing Microsoft Dynamics NAV files, follow these steps:
  1. Close Microsoft Dynamics NAV.
  2. Locate the Microsoft Dynamics NAV Client installation directory. The Microsoft Dynamics NAV Client is usually installed in the following directory:
    C:\Program Files\Microsoft Dynamics NAV\CSIDE Client\
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Client installation directory.
  5. When you are prompted, click Yes to overwrite the files in the installation directory.

Step 2: Replace the Microsoft Dynamics NAV Application Server installation file

If you have Microsoft Dynamics NAV Application Server installed, in the Microsoft Dynamics NAV Application Server installation, replace the following files by using the hotfix or the update file.
File nameFile versionFile sizeDateTimePlatform
Dbm.dll5.0.32009.0434,17609-Dec-201019:53x86
Nas.exe5.0.32009.01,859,58409-Dec-201019:41x86
Nassql.exe5.0.32009.01,916,92809-Dec-201020:19x86
Ndbcs.dll5.0.32009.01,286,14409-Dec-201020:20x86
Slave.exe5.0.32009.0151,55209-Dec-201019:44x86
To replace the files, follow these steps.
  1. Stop the Microsoft Dynamics NAV Application Server.
  2. Locate the Microsoft Dynamics NAV Application Server installation directory. The Microsoft Dynamics NAV Application Server is usually installed in the following directory:
    C:\Program Files\Microsoft Dynamics NAV\Application Server\
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Application Server installation directory.
  5. When you are prompted, click Yes to overwrite the files in the installation directory.
  6. Start the Microsoft Dynamics NAV Application Server.

Step 3: Replace the Microsoft Dynamics NAV ODBC driver installation file

If you have the Microsoft Dynamics NAV ODBC driver installed, replace the following files in the Microsoft Dynamics NAV ODBC driver installation.
File nameFile versionFile sizeDateTimePlatform
Cfront.dll5.0.32009.01,294,33609-Dec-201019:55x86
Dbm.dll5.0.32009.0434,17609-Dec-201019:53x86
Nc_netb.dll5.0.32009.0102,40009-Dec-201019:54x86
Nc_tcp.dll5.0.32009.0102,40009-Dec-201019:54x86
Nc_tcps.dll5.0.32009.0147,45609-Dec-201019:55x86
Nodbc.dll5.0.32009.02,650,11209-Dec-201019:35x86
Nodbc.xmlNot applicable1,20907-Apr-200801:09Not applicable
Nodbccfg.cfg5.0.32009.0614,40009-Dec-201019:36Not applicable
Nodbccfg.xmlNot applicable2,47207-Apr-200801:09Not applicable
Slave.exe5.0.32009.0151,55209-Dec-201019:44x86
To replace the files, follow these steps.
  1. Locate the Microsoft Dynamics NAV ODBC driver installation directory. The Microsoft Dynamics NAV ODBC driver is usually installed in the following directory:
    C:\Program Files\Common Files\Dynamics NAV\NODBC\
  2. Copy the files that you downloaded.
  3. Paste the files that you downloaded into the Microsoft Dynamics NAV ODBC driver installation directory.
  4. When you are prompted, click Yes to overwrite the files in the installation directory.

Prerequisites

You must have Microsoft Dynamics NAV 5.0 Service Pack 1 installed to apply this hotfix.

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Workaround

To work around, edit the cell and mark the cell as "Text Only."

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Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Keywords: kbsurveynew, kbexpertiseinter, kbexpertisebeginner, kbexpertiseadvanced, kbmbsquickpub, kbqfe, kbmbspartner, kbnoloc, kbhotfixserver, kb, kbautohotfix, kbmbsmigrate

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Article Info
Article ID : 2479099
Revision : 3
Created on : 1/31/2017
Published on : 1/31/2017
Exists online : False
Views : 184