Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XWEB: Computer Running Internet Information Service Prompts to Insert Disk in Drive A


View products that this article applies to.

This article was previously published under Q247061

↑ Back to the top


Symptoms

If you use Microsoft Internet Information Service (IIS), a dialog box may be displayed on the computer running IIS that prompts you to insert a disk in drive A. The computer running IIS stops responding until you click Ignore.

↑ Back to the top


Cause

Microsoft Outlook Web Access (OWA) only parses the directory name from a full path string by using a backward slash (\). If a user attaches a file that is wrong, for example, A:/Test.txt, OWA still uses "A:/Test.txt" as the file name (without the path). The global ErrorMode variable is generally set to "SEM_FAILCRITICALERRORS" in the Inetinfo.exe file, so any further processing of the file stops immediately and an error message is generated. However, if the ErrorMode variable is changed, some processes, such as CreateFile, do not stop responding, but they generate a prompt to insert a disk in drive A. Some dynamic-link libraries (DLLs), such as the Mapi32.dll file, actually temporarily change the ErrorMode variable. This problem can occur in a high-stress environment.

↑ Back to the top


Resolution

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server version 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Outlook Web Access

Collapse this tableExpand this table
File nameVersion
Attach.inc5.5.2651.59

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5.

↑ Back to the top


More information

The code in the Attach.inc file is changed so that it parses the path by using either a backward slash (\), a colon (:), or a forward slash (/), so that such invalid characters are not parsed into file names.

↑ Back to the top


Keywords: KB247061, kbqfe, kbfix, kbbug, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 247061
Revision : 7
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 252