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You cannot publish a CRL for an imported certificate after the certificate is revoked in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Active Directory Certificate Services (AD CS) role on a computer that is running Windows Server 2008 R2.
  • You restore a certification authority (CA) database.
  • You import a previously issued certificate into the CA database.
  • You revoke the certificate.
  • You run certutil -crl to publish a certificate revocation list (CRL) for the certificate.
In this scenario, you cannot publish the CRL, and you receive the following error message:
CertUtil: -CRL command FAILED: 0xc0000005 (-1073741819)
CertUtil: The instruction at <memory address> referenced memory at <memory address>. The memory could not be <read/written>.

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Cause

This issue occurs because of an error in AD CS. When a certificate is imported, one property of the certificate is not set. This property specifies whether the certificate should be published in the CRL even after expiration. When the certificate is revoked, and a CRL is published, a NULL pointer dereference occurs. Therefore, you receive the error message.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running the following operating system:

  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)

Additionally, you must have the AD CS role installed on the computer.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.20xxx
    Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Certsrv.exe6.1.7600.20861747,00818-Dec-201006:03x64
Certsvcctrs.hNot applicable1,72110-Jun-200921:03Not applicable
Certsvcctrs.iniNot applicable4,02010-Jun-200921:03Not applicable
Microsoft-windows-certificateservices-ca-ppdlic.xrm-msNot applicable3,49118-Dec-201006:19Not applicable
Certsrv.exe6.1.7601.21624747,00818-Dec-201008:50x64
Certsvcctrs.hNot applicable1,72105-Nov-201002:15Not applicable
Certsvcctrs.iniNot applicable4,02005-Nov-201002:15Not applicable
Microsoft-windows-certificateservices-ca-ppdlic.xrm-msNot applicable3,49118-Dec-201009:05Not applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_bb990da7effd399591d492328c4496e4_31bf3856ad364e35_6.1.7601.21624_none_90d1da64e3b9afd5.manifest
File versionNot applicable
File size714
Date (UTC)20-Dec-2010
Time (UTC)23:59
PlatformNot applicable
File nameAmd64_ff073dccd3a44961c3c7e01f9c4bf36c_31bf3856ad364e35_6.1.7600.20861_none_2c83d0274d969500.manifest
File versionNot applicable
File size714
Date (UTC)20-Dec-2010
Time (UTC)23:59
PlatformNot applicable
File nameAmd64_microsoft-windows-certificateservices-ca_31bf3856ad364e35_6.1.7600.20861_none_3797972d7d2788b1.manifest
File versionNot applicable
File size19,046
Date (UTC)18-Dec-2010
Time (UTC)06:49
PlatformNot applicable
File nameAmd64_microsoft-windows-certificateservices-ca_31bf3856ad364e35_6.1.7601.21624_none_39ac34c17a2ad0de.manifest
File versionNot applicable
File size19,046
Date (UTC)18-Dec-2010
Time (UTC)09:21
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2470092
Revision : 1
Created on : 1/7/2017
Published on : 2/10/2011
Exists online : False
Views : 177