Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you access a WebDAV resource in Windows Server 2008 R2 or in Windows 7: "The folder you entered does not appear to be valid"


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008 R2 or Windows 7.
  • You try to access a WebDAV resource from the computer.
In this scenario, you cannot access the WebDAV resource. Additionally, you receive the following error message:
The folder you entered does not appear to be valid. Please choose another.

Note You can access the resource successfully in Windows Vista and in Windows XP.

↑ Back to the top


Cause

The issue occurs because the Windows Web Client service incorrectly assumes that all XML tags from WebDAV servers contain the namespace prefix "DAV." However, there are some scenarios in which this assumption is incorrect.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems: 
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack (SP1)

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Note If you stop the Windows Web Client service before you install this hotfix, you do not have to restart the computer.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.20xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, very important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Webclnt.dll6.1.7600.20861204,28818-Dec-201005:31x86
Webclnt.dll6.1.7601.21624204,80018-Dec-201007:57x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Webclnt.dll6.1.7600.20861258,04818-Dec-201006:09x64
Webclnt.dll6.1.7601.21624258,56018-Dec-201008:52x64
Webclnt.dll6.1.7600.20861204,28818-Dec-201005:31x86
Webclnt.dll6.1.7601.21624204,80018-Dec-201007:57x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_238bd97f86d9dd32306b1a9f8a1f9221_31bf3856ad364e35_6.1.7600.20861_none_c4de4c763bc8f01f.manifest
File versionNot applicable
File size709
Date (UTC)21-Dec-2010
Time (UTC)00:52
PlatformNot applicable
File nameX86_72cf4b1f88db7136972405318212fa10_31bf3856ad364e35_6.1.7601.21624_none_eb7173f5cd8785ff.manifest
File versionNot applicable
File size709
Date (UTC)21-Dec-2010
Time (UTC)00:52
PlatformNot applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.20861_none_559762f32e16301a.manifest
File versionNot applicable
File size2,413
Date (UTC)18-Dec-2010
Time (UTC)05:59
PlatformNot applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7601.21624_none_57ac00872b197847.manifest
File versionNot applicable
File size2,413
Date (UTC)18-Dec-2010
Time (UTC)08:33
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_238bd97f86d9dd32306b1a9f8a1f9221_31bf3856ad364e35_6.1.7600.20861_none_20fce7f9f4266155.manifest
File versionNot applicable
File size711
Date (UTC)21-Dec-2010
Time (UTC)00:52
PlatformNot applicable
File nameAmd64_5b7c44f78879a47866bce80d62614a94_31bf3856ad364e35_6.1.7600.20861_none_a4a7a312b2f6efe3.manifest
File versionNot applicable
File size1,066
Date (UTC)21-Dec-2010
Time (UTC)00:52
PlatformNot applicable
File nameAmd64_72cf4b1f88db7136972405318212fa10_31bf3856ad364e35_6.1.7601.21624_none_47900f7985e4f735.manifest
File versionNot applicable
File size711
Date (UTC)21-Dec-2010
Time (UTC)00:52
PlatformNot applicable
File nameAmd64_8799772e6065e4acea3f47213d1fd011_31bf3856ad364e35_6.1.7601.21624_none_3f4d7856a3bb0454.manifest
File versionNot applicable
File size713
Date (UTC)21-Dec-2010
Time (UTC)00:52
PlatformNot applicable
File nameAmd64_d2ee56d3d0100b17b5da451dea3f2ef1_31bf3856ad364e35_6.1.7600.20861_none_4d5a445430fe3074.manifest
File versionNot applicable
File size713
Date (UTC)21-Dec-2010
Time (UTC)00:52
PlatformNot applicable
File nameAmd64_d69f740b59c7c0dcac83bde2bfef82ed_31bf3856ad364e35_6.1.7601.21624_none_7a969745b92d13d9.manifest
File versionNot applicable
File size1,066
Date (UTC)21-Dec-2010
Time (UTC)00:52
PlatformNot applicable
File nameAmd64_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.20861_none_b1b5fe76e673a150.manifest
File versionNot applicable
File size2,417
Date (UTC)18-Dec-2010
Time (UTC)06:53
PlatformNot applicable
File nameAmd64_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7601.21624_none_b3ca9c0ae376e97d.manifest
File versionNot applicable
File size2,417
Date (UTC)18-Dec-2010
Time (UTC)09:26
PlatformNot applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.20861_none_559762f32e16301a.manifest
File versionNot applicable
File size2,413
Date (UTC)18-Dec-2010
Time (UTC)05:59
PlatformNot applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7601.21624_none_57ac00872b197847.manifest
File versionNot applicable
File size2,413
Date (UTC)18-Dec-2010
Time (UTC)08:33
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2468498
Revision : 3
Created on : 9/20/2018
Published on : 9/21/2018
Exists online : False
Views : 396