Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Microsoft Dynamics CRM 2011 e-mail router is only configurable against CRM Online


View products that this article applies to.

Symptoms

The Microsoft Dynamics CRM 2011 e-mail router does not allow configuration of the router against Onpremis or SPLA systems.

↑ Back to the top


Cause

The Microsoft Dynamics CRM E-mail Router is not designed to support both CRM Onpremise and CRM Online deployments concurrently. 

↑ Back to the top


Resolution

The Microsoft Dynamics CRM 2011 e-mail router should only be configured against Online or Onpremse,SPLA. The options to configure the router against Onpremise are outlined below.

1. On the computer where the E-mail Router was installed, open the Service folder in the E-mail Router installation folder. If you chose the default installation folder during Setup, this is: <drive>:\Program Files\Microsoft CRM Email\Service
2. Open the file Microsoft.Crm.Tools.Email.Management.config file for editing.
3. Add XML comments (<!-- and -->) around the following statement: <add key="DiscoveryUrl" value="https://dev.crm.dynamics.com" />
4. Save the file.
5. Start the E-mail Router Configuration Manager.

If you created a profile prior to making the changes as described above, you will need to delete the existing deployment profile and create a new deployment profile.

↑ Back to the top


More Information

After Microsoft Dynamics CRM 2011 reaches RTM, the router installation will allow you to choose between installing the router for Microsoft Dynamics CRM Online or Microsoft Dynamics CRM Onpremise 2011

↑ Back to the top


Keywords: kbcrmemail, kbcrminstall, kbcrmsetup, kb

↑ Back to the top

Article Info
Article ID : 2466707
Revision : 1
Created on : 1/7/2017
Published on : 12/8/2010
Exists online : False
Views : 272