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FIX: An SNA application may stop responding after it submits 512 transactions in a 64-bit version of Host Integration Server 2009 or of Host Integration Server 2010


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a client computer that is running a 64-bit version of Microsoft Host Integration Server 2009 or of Microsoft Host Integration Server 2010.
  • You connect the client computer to a server that is running a 32-bit version of Host Integration Server 2009 or of Host Integration Server 2010.
  • You have a 64-bit SNA application (for example APPC, CPI-C, LUA, or 3270) installed on the client computer.
  • You start the SnaBase process on the server.
  • You start the SNA application on the client computer five minutes or more after the SnaBase process is started.
  • The SNA application submits 512 transaction requests to the server.
In this scenario, the SNA application may stop responding.

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Cause

This issue occurs when the Host Integration Server client receives a response from the 32-bit Host Integration Server system. In this situation, the SnaBase process on the Host Integration Server client does not release entries in an array that stores the 64-bit pointer to 32-bit index mappings. When the number of entries in the array reaches the limit of 512, the SNA application cannot process more requests.

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Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Host Integration Server 2009 or Microsoft Host Integration Server 2010 installed.

Restart information

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File information for Host Integration Server 2009 and for Host Integration Server 2010

For all supported x86-based versions of Host Integration Server 2009
File nameFile versionFile sizeDateTimePlatform
Snabase.exe8.0.3787.2252,24011-Nov-201018:03x86
For all supported x64-based versions of Host Integration Server 2009
File nameFile versionFile sizeDateTimePlatform
Snabase.exe8.0.3787.2293,71211-Nov-201018:08x64
For all supported x86-based versions of Host Integration Server 2010
File nameFile versionFile sizeDateTimePlatform
Snabase.exe8.5.4250.2264,01613-Nov-201001:52x86
For all supported x64-based versions of Host Integration Server 2010
File nameFile versionFile sizeDateTimePlatform
Snabase.exe8.5.4250.2296,27213-Nov-201001:56x64
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2459642
Revision : 1
Created on : 1/7/2017
Published on : 12/29/2010
Exists online : False
Views : 431