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“Access Denied” error trying to rename a file on share available offline


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Symptoms

Consider the following scenario:

A user is working offline, and tries to rename a file on a share that is offline. The user renames the file to the same name, but with a different case (UPPERCASE lowercase). 

For example, a user renames an offline file from all.txt to All.txt.

The operation will fail with on-screen error "Access Denied - Try Again".

For example if you have a file named “ALLUPPERCASE.TXT” and want to rename it in Explorer to “AllUpperCase.txt”
you will be denied if the file is set to be always available offline.

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Cause

This is a known issue issue with offline files (CSC).

Offline Files (CSC or Client Side Cache) prevents users from changing the case of file names once those files are made available offline.

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Resolution

Workaround #1


To work around the issue, change the name of the file that you are wanting to rename to a different name first, then rename that file to the original name with the different case sensitiveness. 

e.g. all.txt rename to All2.txt rename to All.txt

Workaround #2

Assuming that the user has the following FQDN path in the CSC offline cache
\\DFSserver.Contoso.com\DFSroot\UserHome\UserName\all.txt 
 

it will be still possible to rename the file or folder using the NetBIOS name of the server, for example 
\\DFSserver\DFSroot\UserHome\UserName\all.txt 

or using the IP-address of the server
\\10.10.10.1\DFSroot\UserHome\UserName\all.txtall.txt 


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Keywords: kb

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Article Info
Article ID : 2457622
Revision : 1
Created on : 1/7/2017
Published on : 3/1/2011
Exists online : False
Views : 537