Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Windows backup fails when you back up data from the root folder of a mount point


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running one of the following operating systems:
    • Windows Server 2008 R2
    • Windows 7
    • Windows Server 2008
    • Windows Vista
  • You install an application that uses transactional logging on the computer, such as Microsoft SQL Server or Microsoft Exchange Server.
  • The log file of the application is saved on the root folder of a mount point.
  • You try to use the Windows backup engine to back up the application.

In this scenario, the backup operation fails, and you receive the following error message:

Log of files successfully backed up
'path of Log-File'
Log of files for which backup failed
'path of Log-File'
Failure in a Volume Shadow Copy Service operation.
ERROR - Volume Shadow Copy Service operation error <0x800423f0> the shadow copy set only contains only a subset of the volumes needed to correctly backup the selected components of the writer.

After you receive this error message, you run the Vssadmin list writers command. This results in the application writer being in the following state:

State: [8] Failed
Last error: Inconsistent shadow copy

↑ Back to the top


Cause

This problem occurs because the XML metadata that is created by the log writer on the computer differs from the metadata that the Windows backup engine expects. If the file path for the log files points to the root of a mount point, the Windows backup engine expects the physical path for the log files to end with a trailing backslash. However, the log writer returns the physical path information without a trailing backslash. Therefore, this causes the issue to occur.

Problems with the log writer can also cause a different problem that is documented in the following Microsoft Knowledge Base article:
977179 You receive an "0x800423f0" error message when you perform system state backups on the passive node of Windows Server 2008-based Exchange Server 2007 CCR clusters

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Spp.dll6.0.6002.22641142,33612-May-201115:11x86
Sxproxy.dll6.0.6002.2264128,16012-May-201115:12x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Spp.dll6.0.6002.22641188,92812-May-201115:30x64
Sxproxy.dll6.0.6002.2264159,90412-May-201115:30x64
Spp.dll6.0.6002.22641142,33612-May-201115:11x86
Sxproxy.dll6.0.6002.2264128,16012-May-201115:12x86
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Spp.dll6.0.6002.22641393,21612-May-201115:31IA-64
Sxproxy.dll6.0.6002.2264170,65612-May-201115:31IA-64

Windows 7 and Windows Server 2008 R2 file information notes

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.7600.20xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.7601.21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Spp.dll6.1.7600.20876172,54408-Jan-201105:35x86
Spp.dll6.1.7601.21637172,54408-Jan-201105:36x86
For all supported x64-based versions of Windows Server 2008 R2 and of Windows 7
File nameFile versionFile sizeDateTimePlatform
Spp.dll6.1.7600.20876244,22408-Jan-201106:18x64
Spp.dll6.1.7600.20876172,54408-Jan-201105:35x86
Spp.dll6.1.7601.21637244,22408-Jan-201106:13x64
Spp.dll6.1.7601.21637172,54408-Jan-201105:36x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Spp.dll6.1.7600.20876493,05608-Jan-201105:16IA-64
Spp.dll6.1.7601.21637493,05608-Jan-201105:12IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size3,594
Date (UTC)12-May-2011
Time (UTC)18:07
PlatformNot Applicable
File nameX86_microsoft-windows-spp-main_31bf3856ad364e35_6.0.6002.22641_none_e68cd53ec340374e.manifest
File versionNot Applicable
File size48,756
Date (UTC)12-May-2011
Time (UTC)15:26
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_microsoft-windows-spp-main_31bf3856ad364e35_6.0.6002.22641_none_42ab70c27b9da884.manifest
File versionNot Applicable
File size48,778
Date (UTC)12-May-2011
Time (UTC)15:44
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,952
Date (UTC)12-May-2011
Time (UTC)18:07
PlatformNot Applicable
File nameX86_microsoft-windows-spp-main_31bf3856ad364e35_6.0.6002.22641_none_e68cd53ec340374e.manifest
File versionNot Applicable
File size48,756
Date (UTC)12-May-2011
Time (UTC)15:26
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_microsoft-windows-spp-main_31bf3856ad364e35_6.0.6002.22641_none_e68e7934c33e404a.manifest
File versionNot Applicable
File size48,767
Date (UTC)12-May-2011
Time (UTC)15:39
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,760
Date (UTC)12-May-2011
Time (UTC)18:07
PlatformNot Applicable

Additional file information for Windows Server 2008 R2 and for Windows 7



Additional files for all supported x86-based versions of Windows 7
File nameX86_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7600.20876_none_e4b2c17e2744f74a.manifest
File versionNot Applicable
File size34,814
Date (UTC)10-Jan-2011
Time (UTC)14:03
File nameX86_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7601.21637_none_e6c55e7e244a0cc9.manifest
File versionNot Applicable
File size34,814
Date (UTC)10-Jan-2011
Time (UTC)14:03
Additional files for all supported x64-based versions of Windows Server 2008 R2 and of Windows 7
File nameAmd64_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7600.20876_none_40d15d01dfa26880.manifest
File versionNot Applicable
File size34,818
Date (UTC)10-Jan-2011
Time (UTC)14:07
File nameAmd64_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7601.21637_none_42e3fa01dca77dff.manifest
File versionNot Applicable
File size34,818
Date (UTC)10-Jan-2011
Time (UTC)14:07
File nameX86_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7600.20876_none_e4b2c17e2744f74a.manifest
File versionNot Applicable
File size34,814
Date (UTC)10-Jan-2011
Time (UTC)14:07
File nameX86_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7601.21637_none_e6c55e7e244a0cc9.manifest
File versionNot Applicable
File size34,814
Date (UTC)10-Jan-2011
Time (UTC)14:07
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7600.20876_none_e4b4657427430046.manifest
File versionNot Applicable
File size34,816
Date (UTC)10-Jan-2011
Time (UTC)14:00
File nameIa64_microsoft-windows-spp-main_31bf3856ad364e35_6.1.7601.21637_none_e6c70274244815c5.manifest
File versionNot Applicable
File size34,816
Date (UTC)10-Jan-2011
Time (UTC)14:00

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2457458
Revision : 2
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 406